Every CVE Search/ Get API key

CVE-2009-0039

Apache Geronimo Application Server CSRF vulnerabilities

6.8 MediumPublic exploitFix available

Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.

Exploit likelihood

11.1%Down 5.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.

Record
CVE-2009-0039
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.

Record
CVE-2009-0039
Updated
2026-11-02
EUVDEUVD-2022-2738 No score

Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.

Record
EUVD-2022-2738
Updated
2026-11-03
GitHub AdvisoriesGHSA-678x-xfp4-r92r No score

Apache Geronimo Application Server CSRF vulnerabilities

Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.

Record
GHSA-678x-xfp4-r92r
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-678x-xfp4-r92r No score

Apache Geronimo Application Server CSRF vulnerabilities

Multiple cross-site request forgery (CSRF) vulnerabilities in the web administration console in Apache Geronimo Application Server 2.1 through 2.1.3 allow remote attackers to hijack the authentication of administrators for requests that (1) change the web administration password, (2) upload applications, and perform unspecified other administrative actions, as demonstrated by (3) a Shutdown request to console/portal//Server/Shutdown.

Record
GHSA-678x-xfp4-r92r
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.geronimo.plugins:console
Maven
before 2.1.4
2.1.4
org.apache.geronimo.plugins:console
Maven
before 2.1.4, plus listed versions
2.12.1.12.1.22.1.3
2.1.4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBApache Geronimo 2.1.x - Cross-Site Request Forgery (Multiple Admin Function)2009-04-16

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0039 is a medium vulnerability (CVSS 6.8) in Apache Geronimo, published April 17, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.1%, the 95th percentile. Fixed in org.apache.geronimo.plugins:console 2.1.4.

References

Show 5 moreShow less
MoveEnter Open