Every CVE Search/ Get API key

CVE-2009-0153

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac...

4.3 MediumFix available

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac OS X 10.5 before 10.5.7, iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Fedora 9 and 10, and possibly other operating systems, does not properly handle invalid byte sequences during Unicode conversion, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.

Exploit likelihood

3.68%Down 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac OS X 10.5 before 10.5.7, iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Fedora 9 and 10, and possibly other operating systems, does not properly handle invalid byte sequences during Unicode conversion, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.

Record
CVE-2009-0153
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac OS X 10.5 before 10.5.7, iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Fedora 9 and 10, and possibly other operating systems, does not properly handle invalid byte sequences during Unicode conversion, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.

Record
CVE-2009-0153
Updated
2026-11-02
EUVDEUVD-2009-0162 No score

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac OS X 10.5 before 10.5.7, iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Fedora 9 and 10, and possibly other operating systems, does not properly handle invalid byte sequences during Unicode conversion, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.

Record
EUVD-2009-0162
Updated
2026-11-03
GitHub AdvisoriesGHSA-hc72-qh6j-jvwc No score

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac...

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac OS X 10.5 before 10.5.7, iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Fedora 9 and 10, and possibly other operating systems, does not properly handle invalid byte sequences during Unicode conversion, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.

Record
GHSA-hc72-qh6j-jvwc
Weakness
CWE-79
Updated
2026-11-02
OSVRHSA-2009:1122 6.1

Red Hat Security Advisory: icu security update

Record
RHSA-2009:1122
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSV No score

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac OS X 10.5 before 10.5.7, iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Fedora 9 and 10, and possibly other operating systems, does not properly handle invalid byte sequences during Unicode conversion, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.

Record
CVE-2009-0153
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0153 No score

International Components for Unicode (ICU) 4.0, 3.6, and other 3.x versions, as used in Apple Mac OS X 10.5 before 10.5.7, iPhone OS 1.0 through 2.2.1, iPhone OS for iPod touch 1.1 through 2.2.1, Fedora 9 and 10, and possibly other operating systems, does not properly handle invalid byte sequences during Unicode conversion, which might allow remote attackers to conduct cross-site scripting (XSS) attacks.

Record
DEBIAN-CVE-2009-0153
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
icu
Debian:12
before 4.0.1-1
4.0.1-1
icu
Debian:13
before 4.0.1-1
4.0.1-1
icu
Debian:14
before 4.0.1-1
4.0.1-1
icu
Debian:4.0
before 3.6-2etch3, plus listed versions
3.6-23.6-2etch13.6-2etch2
3.6-2etch3
icu
Debian:5.0
before 3.8.1-3+lenny2, plus listed versions
3.8.1-33.8.1-3+lenny1
3.8.1-3+lenny2
icu
Red Hat:enterprise_linux:5::client_workstation
before 0:3.6-5.11.4
0:3.6-5.11.4
icu-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:3.6-5.11.4
0:3.6-5.11.4
libicu-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:3.6-5.11.4
0:3.6-5.11.4
icu
Red Hat:enterprise_linux:5::client
before 0:3.6-5.11.4
0:3.6-5.11.4
icu-debuginfo
Red Hat:enterprise_linux:5::client
before 0:3.6-5.11.4
0:3.6-5.11.4
Show 7 moreShow less
Affected packages
PackageAffectedFixed
libicu
Red Hat:enterprise_linux:5::client
before 0:3.6-5.11.4
0:3.6-5.11.4
libicu-doc
Red Hat:enterprise_linux:5::client
before 0:3.6-5.11.4
0:3.6-5.11.4
icu
Red Hat:enterprise_linux:5::server
before 0:3.6-5.11.4
0:3.6-5.11.4
icu-debuginfo
Red Hat:enterprise_linux:5::server
before 0:3.6-5.11.4
0:3.6-5.11.4
libicu
Red Hat:enterprise_linux:5::server
before 0:3.6-5.11.4
0:3.6-5.11.4
libicu-devel
Red Hat:enterprise_linux:5::server
before 0:3.6-5.11.4
0:3.6-5.11.4
libicu-doc
Red Hat:enterprise_linux:5::server
before 0:3.6-5.11.4
0:3.6-5.11.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0153 is a medium vulnerability (CVSS 4.3) in Apple Mac Os X, published May 13, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.68%, the 89th percentile. Fixed in icu 4.0.1-1.

References

Show 26 moreShow less
MoveEnter Open