Every CVE Search/ Get API key

CVE-2009-0165

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other...

10.0 HighFix available

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other products, when running on Mac OS X, has unspecified impact, related to "g*allocn."

Exploit likelihood

3.59%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other products, when running on Mac OS X, has unspecified impact, related to "g*allocn."

Record
CVE-2009-0165
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other products, when running on Mac OS X, has unspecified impact, related to "g*allocn."

Record
CVE-2009-0165
Updated
2026-11-02
EUVDEUVD-2009-0174 No score

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other products, when running on Mac OS X, has unspecified impact, related to "g*allocn."

Record
EUVD-2009-0174
Updated
2026-11-03
GitHub AdvisoriesGHSA-qx4p-wc3g-wr66 No score

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other...

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other products, when running on Mac OS X, has unspecified impact, related to "g*allocn."

Record
GHSA-qx4p-wc3g-wr66
Updated
2026-11-02
OSV No score

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other products, when running on Mac OS X, has unspecified impact, related to "g*allocn."

Record
CVE-2009-0165
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0165 No score

Integer overflow in the JBIG2 decoder in Xpdf 3.02pl2 and earlier, as used in Poppler and other products, when running on Mac OS X, has unspecified impact, related to "g*allocn."

Record
DEBIAN-CVE-2009-0165
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xpdf
Debian:12
before 3.02-1.4+lenny1
3.02-1.4+lenny1
xpdf
Debian:13
before 3.02-1.4+lenny1
3.02-1.4+lenny1
xpdf
Debian:14
before 3.02-1.4+lenny1
3.02-1.4+lenny1
xpdf
Debian:4.0
before 3.01-9.1+etch6, plus listed versions
3.01-93.01-9.1+etch23.01-9.1+etch43.01-9.1+etch53.01-9etch1
3.01-9.1+etch6
xpdf
Debian:5.0
before 3.02-1.4+lenny1, plus listed versions
3.02-1.4
3.02-1.4+lenny1
kdegraphics
Debian:4.0
before 4:3.5.5-3etch3, plus listed versions
4:3.5.5-34:3.5.5-3etch14:3.5.5-3etch2
4:3.5.5-3etch3
kdegraphics
Debian:5.0
before 4:3.5.9-3+lenny1, plus listed versions
4:3.5.9-3
4:3.5.9-3+lenny1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0165 is a high vulnerability (CVSS 10.0) in Foolabs Xpdf, published April 23, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.59%, the 89th percentile. Fixed in xpdf 3.02-1.4+lenny1.

References

Show 21 moreShow less
MoveEnter Open