Every CVE Search/ Get API key

CVE-2009-0240

listing.php in WebSVN 2.0 and possibly 1.7 beta, when using an SVN authz file, allows remote...

3.5 LowFix available

listing.php in WebSVN 2.0 and possibly 1.7 beta, when using an SVN authz file, allows remote authenticated users to read changelogs or diffs for restricted projects via a modified repname parameter.

Exploit likelihood

1.60%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 3.5

listing.php in WebSVN 2.0 and possibly 1.7 beta, when using an SVN authz file, allows remote authenticated users to read changelogs or diffs for restricted projects via a modified repname parameter.

Record
CVE-2009-0240
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:P/I:N/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

listing.php in WebSVN 2.0 and possibly 1.7 beta, when using an SVN authz file, allows remote authenticated users to read changelogs or diffs for restricted projects via a modified repname parameter.

Record
CVE-2009-0240
Updated
2026-11-02
EUVDEUVD-2009-0248 No score

listing.php in WebSVN 2.0 and possibly 1.7 beta, when using an SVN authz file, allows remote authenticated users to read changelogs or diffs for restricted projects via a modified repname parameter.

Record
EUVD-2009-0248
Updated
2026-11-03
GitHub AdvisoriesGHSA-v46j-c2c5-8xp7 No score

listing.php in WebSVN 2.0 and possibly 1.7 beta, when using an SVN authz file, allows remote...

listing.php in WebSVN 2.0 and possibly 1.7 beta, when using an SVN authz file, allows remote authenticated users to read changelogs or diffs for restricted projects via a modified repname parameter.

Record
GHSA-v46j-c2c5-8xp7
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
websvn
Debian:5.0
before 2.0-4+lenny1, plus listed versions
2.0-4
2.0-4+lenny1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0240 is a low vulnerability (CVSS 3.5) in Tigris Websvn, published January 21, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.60%, the 75th percentile. Fixed in websvn 2.0-4+lenny1.

References

Show 4 moreShow less
MoveEnter Open