Every CVE Search/ Get API key

CVE-2009-0361

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other...

4.6 MediumFix available

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.

Exploit likelihood

0.38%Down 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.6

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.

Record
CVE-2009-0361
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.

Record
CVE-2009-0361
Updated
2026-11-02
EUVDEUVD-2009-0365 No score

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.

Record
EUVD-2009-0365
Updated
2026-11-03
GitHub AdvisoriesGHSA-rcf3-vv2f-fwg2 No score

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other...

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.

Record
GHSA-rcf3-vv2f-fwg2
Updated
2026-11-02
OSV No score

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.

Record
CVE-2009-0361
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0361 No score

Russ Allbery pam-krb5 before 3.13, as used by libpam-heimdal, su in Solaris 10, and other software, does not properly handle calls to pam_setcred when running setuid, which allows local users to overwrite and change the ownership of arbitrary files by setting the KRB5CCNAME environment variable, and then launching a setuid application that performs certain pam_setcred operations.

Record
DEBIAN-CVE-2009-0361
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libpam-krb5
Debian:12
before 3.13-2
3.13-2
libpam-krb5
Debian:13
before 3.13-2
3.13-2
libpam-krb5
Debian:14
before 3.13-2
3.13-2
libpam-krb5
Debian:4.0
From an advisory covering 2 CVEs
before 2.6-1etch1, plus listed versions
2.6-1
2.6-1etch1
libpam-heimdal
Debian:4.0
before 2.5-1etch1, plus listed versions
2.5-1
2.5-1etch1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0361 is a medium vulnerability (CVSS 4.6) in Eyrie Pam-krb5, published February 11, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 32nd percentile. Fixed in libpam-krb5 3.13-2.

References

Show 17 moreShow less
MoveEnter Open