Every CVE Search/ Get API key

CVE-2009-0543

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection...

6.8 MediumPublic exploitFix available

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

Exploit likelihood

15.8%Up 14.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

Record
CVE-2009-0543
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

Record
CVE-2009-0543
Updated
2026-11-02
EUVDEUVD-2009-0547 No score

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

Record
EUVD-2009-0547
Updated
2026-11-03
GitHub AdvisoriesGHSA-3qqr-wq7g-hxwh No score

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection...

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

Record
GHSA-3qqr-wq7g-hxwh
Weakness
CWE-89
Updated
2026-11-02
OSV No score

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

Record
CVE-2009-0543
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0543 No score

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

Record
DEBIAN-CVE-2009-0543
Updated
2026-11-02
OSVopenSUSE-SU-2024:10048-1 No score

proftpd-1.3.5b-2.5 on GA media

These are all security issues fixed in the proftpd-1.3.5b-2.5 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10048-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
proftpd-dfsg
Debian:12
before 1.3.2-1
1.3.2-1
proftpd-dfsg
Debian:13
before 1.3.2-1
1.3.2-1
proftpd-dfsg
Debian:14
before 1.3.2-1
1.3.2-1
proftpd-dfsg
Debian:5.0
From an advisory covering 2 CVEs
before 1.3.1-17lenny1, plus listed versions
1.3.1-161.3.1-17
1.3.1-17lenny1
proftpd-dfsg
Debian:5.0
From an advisory covering 2 CVEs
before 1.3.1-17lenny2, plus listed versions
1.3.1-161.3.1-171.3.1-17lenny11.3.1-17lenny2~bpo40+1
1.3.1-17lenny2
proftpd
openSUSE:Tumbleweed
From an advisory covering 8 CVEs
before 1.3.5b-2.5
1.3.5b-2.5

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBProFTPd - 'mod_mysql' Authentication Bypass2009-02-10

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0543 is a medium vulnerability (CVSS 6.8) in Proftpd, published February 12, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 15.8%, the 96th percentile. Fixed in proftpd-dfsg 1.3.2-1.

References

Show 12 moreShow less
MoveEnter Open