Every CVE Search/ Get API key

CVE-2009-0755

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to...

5.0 MediumPublic exploitFix available

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.

Exploit likelihood

10.8%Up 7.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.

Record
CVE-2009-0755
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.

Record
CVE-2009-0755
Updated
2026-11-02
EUVDEUVD-2009-0755 No score

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.

Record
EUVD-2009-0755
Updated
2026-11-03
GitHub AdvisoriesGHSA-jmc7-m54g-vwh9 No score

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to...

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.

Record
GHSA-jmc7-m54g-vwh9
Updated
2026-11-02
OSV No score

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.

Record
CVE-2009-0755
Updated
2026-11-02
OSVDEBIAN-CVE-2009-0755 No score

The FormWidgetChoice::loadDefaults function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file with an invalid Form Opt entry.

Record
DEBIAN-CVE-2009-0755
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
poppler
Debian:12
before 0.10.6-1
0.10.6-1
poppler
Debian:13
before 0.10.6-1
0.10.6-1
poppler
Debian:14
before 0.10.6-1
0.10.6-1
poppler
Debian:5.0
From an advisory covering 10 CVEs
before 0.8.7-3, plus listed versions
0.8.7-10.8.7-2
0.8.7-3

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBPoppler 0.10.3 - Denial of Service2009-02-12

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-0755 is a medium vulnerability (CVSS 5.0) in Poppler, published March 3, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 10.8%, the 95th percentile. Fixed in poppler 0.10.6-1.

References

Show 10 moreShow less
MoveEnter Open