CVE-2009-1184
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux...
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux subsystem in the Linux kernel before 2.6.27.22, and 2.6.28.x before 2.6.28.10, when compat_net is enabled, omits calls to avc_has_perm for the (1) node and (2) port, which allows local users to bypass intended restrictions on network traffic. NOTE: this was incorrectly reported as an issue fixed in 2.6.27.21.
Exploit likelihood
What each source reports
NVD Score used
4.4
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux subsystem in the Linux kernel before 2.6.27.22, and 2.6.28.x before 2.6.28.10, when compat_net is enabled, omits calls to avc_has_perm for the (1) node and (2) port, which allows local users to bypass intended restrictions on network traffic. NOTE: this was incorrectly reported as an issue fixed in 2.6.27.21.
- Record
CVE-2009-1184- CVSS 2.0
- 4.4 Medium
AV:L/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-16
- Updated
- 2026-11-02
CVE List No score
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux subsystem in the Linux kernel before 2.6.27.22, and 2.6.28.x before 2.6.28.10, when compat_net is enabled, omits calls to avc_has_perm for the (1) node and (2) port, which allows local users to bypass intended restrictions on network traffic. NOTE: this was incorrectly reported as an issue fixed in 2.6.27.21.
- Record
CVE-2009-1184- Updated
- 2026-11-02
EUVDEUVD-2009-1184 No score
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux subsystem in the Linux kernel before 2.6.27.22, and 2.6.28.x before 2.6.28.10, when compat_net is enabled, omits calls to avc_has_perm for the (1) node and (2) port, which allows local users to bypass intended restrictions on network traffic. NOTE: this was incorrectly reported as an issue fixed in 2.6.27.21.
- Record
EUVD-2009-1184- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jcfv-mgf6-qw9x No score
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux...
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux subsystem in the Linux kernel before 2.6.27.22, and 2.6.28.x before 2.6.28.10, when compat_net is enabled, omits calls to avc_has_perm for the (1) node and (2) port, which allows local users to bypass intended restrictions on network traffic. NOTE: this was incorrectly reported as an issue fixed in 2.6.27.21.
- Record
GHSA-jcfv-mgf6-qw9x- Updated
- 2026-11-02
OSVBELL-CVE-2009-1184
4.4
CVE-2009-1184 does not affect BellSoft software
- Record
BELL-CVE-2009-1184- CVSS 2.0
- 4.4 Medium
AV:L/AC:M/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
linux-2.6Debian:5.0 From an advisory covering 13 CVEs |
before 2.6.26-15lenny2, plus listed versions 2.6.26-132.6.26-13lenny22.6.26-13lenny2~bpo40+12.6.26-142.6.26-152.6.26-15lenny12.6.26-15~bpo40+12.6.26-15~bpo40+2 |
2.6.26-15lenny2 |
user-mode-linuxDebian:5.0 From an advisory covering 13 CVEs |
before 2.6.26-1um-2+15lenny2, plus listed versions 2.6.26-1um-22.6.26-1um-2+15 |
2.6.26-1um-2+15lenny2 |
user-mode-linuxDebian:5.0 From an advisory covering 4 CVEs |
before 2.6.26-1um-2+15lenny3, plus listed versions 2.6.26-1um-22.6.26-1um-2+152.6.26-1um-2+15lenny2 |
2.6.26-1um-2+15lenny3 |
linux-2.6Debian:5.0 From an advisory covering 4 CVEs |
before 2.6.26-15lenny3, plus listed versions 2.6.26-132.6.26-13lenny22.6.26-13lenny2~bpo40+12.6.26-142.6.26-15 Show 4 moreShow less2.6.26-15lenny12.6.26-15lenny22.6.26-15~bpo40+12.6.26-15~bpo40+2 |
2.6.26-15lenny3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-1184 is a medium vulnerability (CVSS 4.4) in Linux Kernel, published May 5, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 28th percentile. No source names a fixed version.
References
mandriva.com/security/advisories?name=MDVSA-2009:135
lwn.net/Articles/331435
mandriva.com/security/advisories?name=MDVSA-2009:118
secunia.com/advisories/35656
openwall.com/lists/oss-security/2009/05/04/1
patchwork.ozlabs.org/patch/25238
Show 11 moreShow less
ubuntu.com/usn/usn-793-1
debian.org/security/2009/dsa-1800
git.kernel.org?p=linux/kernel/git/stable/linux-2.6.27.y.git%3Ba=commit%3Bh=910c9e41186762de3717baaf392ab5ff0c454496
launchpad.net/bugs/cve/2009-1184
lwn.net/Articles/331434
mandriva.com/security/advisories?name=MDVSA-2009:119
secunia.com/advisories/35121
nvd.nist.gov/vuln/detail/CVE-2009-1184
git.kernel.org?p=linux/kernel/git/stable/linux-2.6.27.y.git;a=commit;h=910c9e41186762de3717baaf392ab5ff0c454496
github.com/advisories/GHSA-jcfv-mgf6-qw9x
docs.bell-sw.com/security/cves/CVE-2009-1184