Every CVE Search/ Get API key

CVE-2009-1364

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context...

7.5 HighFix available

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.

Exploit likelihood

3.46%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.

Record
CVE-2009-1364
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.

Record
CVE-2009-1364
Updated
2026-11-02
EUVDEUVD-2009-1362 No score

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.

Record
EUVD-2009-1362
Updated
2026-11-03
GitHub AdvisoriesGHSA-6h8h-vx9v-4g94 No score

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context...

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.

Record
GHSA-6h8h-vx9v-4g94
Updated
2026-11-02
OSV No score

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.

Record
CVE-2009-1364
Updated
2026-11-02
OSVDEBIAN-CVE-2009-1364 No score

Use-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.

Record
DEBIAN-CVE-2009-1364
Updated
2026-11-02
OSVSUSE-SU-2015:1484-1 No score

Security update for libwmf

libwmf was updated to fix five security issues.

These security issues were fixed:

  • CVE-2009-1364: Fixed realloc return value usage (bsc#495842, bnc#831299)
  • CVE-2015-0848: Heap overflow on libwmf0.2-7 (bsc#933109)
  • CVE-2015-4588: DecodeImage() did not check that the run-length 'count' fits into the total size of the image, which could lead to a heap-based buffer overflow (bsc#933109)
  • CVE-2015-4695: meta_pen_create heap buffer over read (bsc#936058)
  • CVE-2015-4696: Use after free (bsc#936062)
Record
SUSE-SU-2015:1484-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libwmf
Debian:12
before 0.2.8.4-6.1
0.2.8.4-6.1
libwmf
Debian:13
before 0.2.8.4-6.1
0.2.8.4-6.1
libwmf
Debian:14
before 0.2.8.4-6.1
0.2.8.4-6.1
libwmf
Debian:4.0
before 0.2.8.4-2+etch1, plus listed versions
0.2.8.4-2
0.2.8.4-2+etch1
libwmf
Debian:5.0
before 0.2.8.4-6+lenny1, plus listed versions
0.2.8.4-6
0.2.8.4-6+lenny1
libwmf
Red Hat:enterprise_linux:4::as
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf-debuginfo
Red Hat:enterprise_linux:4::as
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf-devel
Red Hat:enterprise_linux:4::as
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf
Red Hat:enterprise_linux:4::desktop
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
Show 18 moreShow less
Affected packages
PackageAffectedFixed
libwmf-devel
Red Hat:enterprise_linux:4::desktop
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf
Red Hat:enterprise_linux:4::es
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf-debuginfo
Red Hat:enterprise_linux:4::es
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf-devel
Red Hat:enterprise_linux:4::es
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf
Red Hat:enterprise_linux:4::ws
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf-devel
Red Hat:enterprise_linux:4::ws
before 0:0.2.8.3-5.8
0:0.2.8.3-5.8
libwmf
Red Hat:enterprise_linux:5::client_workstation
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf
Red Hat:enterprise_linux:5::client
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf-debuginfo
Red Hat:enterprise_linux:5::client
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf
Red Hat:enterprise_linux:5::server
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf-debuginfo
Red Hat:enterprise_linux:5::server
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf-devel
Red Hat:enterprise_linux:5::server
before 0:0.2.8.4-10.2
0:0.2.8.4-10.2
libwmf
SUSE:Linux Enterprise Desktop 12
From an advisory covering 5 CVEs
before 0.2.8.4-242.3
0.2.8.4-242.3
libwmf
SUSE:Linux Enterprise Software Development Kit 12
From an advisory covering 5 CVEs
before 0.2.8.4-242.3
0.2.8.4-242.3
libwmf
SUSE:Linux Enterprise Workstation Extension 12
From an advisory covering 5 CVEs
before 0.2.8.4-242.3
0.2.8.4-242.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1364 is a high vulnerability (CVSS 7.5) in Francis James Franklin Libwmf, published May 1, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.46%, the 89th percentile. Fixed in libwmf 0.2.8.4-6.1.

References

Show 39 moreShow less
MoveEnter Open