Every CVE Search/ Get API key

CVE-2009-1572

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of...

5.0 MediumFix available

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of service (crash) via an AS path containing ASN elements whose string representation is longer than expected, which triggers an assert error.

Exploit likelihood

3.52%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of service (crash) via an AS path containing ASN elements whose string representation is longer than expected, which triggers an assert error.

Record
CVE-2009-1572
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of service (crash) via an AS path containing ASN elements whose string representation is longer than expected, which triggers an assert error.

Record
CVE-2009-1572
Updated
2026-11-02
EUVDEUVD-2009-1568 No score

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of service (crash) via an AS path containing ASN elements whose string representation is longer than expected, which triggers an assert error.

Record
EUVD-2009-1568
Updated
2026-11-03
GitHub AdvisoriesGHSA-7pv4-f272-hv95 No score

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of...

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of service (crash) via an AS path containing ASN elements whose string representation is longer than expected, which triggers an assert error.

Record
GHSA-7pv4-f272-hv95
Updated
2026-11-02
OSV No score

The BGP daemon (bgpd) in Quagga 0.99.11 and earlier allows remote attackers to cause a denial of service (crash) via an AS path containing ASN elements whose string representation is longer than expected, which triggers an assert error.

Record
CVE-2009-1572
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
quagga
Debian:5.0
before 0.99.10-1lenny2, plus listed versions
0.99.10-1lenny1
0.99.10-1lenny2

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1572 is a medium vulnerability (CVSS 5.0) in Quagga, published May 4, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.52%, the 89th percentile. Fixed in quagga 0.99.10-1lenny2.

References

Show 15 moreShow less
MoveEnter Open