Every CVE Search/ Get API key

CVE-2009-1581

functions/mime.php in SquirrelMail before 1.4.18 does not protect the application's content from...

4.3 MediumFix available

functions/mime.php in SquirrelMail before 1.4.18 does not protect the application's content from Cascading Style Sheets (CSS) positioning in HTML e-mail messages, which allows remote attackers to spoof the user interface, and conduct cross-site scripting (XSS) and phishing attacks, via a crafted message.

Exploit likelihood

1.75%Down 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

functions/mime.php in SquirrelMail before 1.4.18 does not protect the application's content from Cascading Style Sheets (CSS) positioning in HTML e-mail messages, which allows remote attackers to spoof the user interface, and conduct cross-site scripting (XSS) and phishing attacks, via a crafted message.

Record
CVE-2009-1581
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

functions/mime.php in SquirrelMail before 1.4.18 does not protect the application's content from Cascading Style Sheets (CSS) positioning in HTML e-mail messages, which allows remote attackers to spoof the user interface, and conduct cross-site scripting (XSS) and phishing attacks, via a crafted message.

Record
CVE-2009-1581
Updated
2026-11-02
EUVDEUVD-2009-1577 No score

functions/mime.php in SquirrelMail before 1.4.18 does not protect the application's content from Cascading Style Sheets (CSS) positioning in HTML e-mail messages, which allows remote attackers to spoof the user interface, and conduct cross-site scripting (XSS) and phishing attacks, via a crafted message.

Record
EUVD-2009-1577
Updated
2026-11-03
GitHub AdvisoriesGHSA-x532-p2m7-cf32 No score

functions/mime.php in SquirrelMail before 1.4.18 does not protect the application's content from...

functions/mime.php in SquirrelMail before 1.4.18 does not protect the application's content from Cascading Style Sheets (CSS) positioning in HTML e-mail messages, which allows remote attackers to spoof the user interface, and conduct cross-site scripting (XSS) and phishing attacks, via a crafted message.

Record
GHSA-x532-p2m7-cf32
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
squirrelmail
Debian:4.0
before 2:1.4.9a-4, plus listed versions
2:1.4.9a-12:1.4.9a-22:1.4.9a-3
2:1.4.9a-4
squirrelmail
Debian:5.0
before 2:1.4.15-4+lenny1, plus listed versions
2:1.4.15-4
2:1.4.15-4+lenny1
squirrelmail
Red Hat:enterprise_linux:3::as
before 0:1.4.8-13.el3
0:1.4.8-13.el3
squirrelmail
Red Hat:enterprise_linux:3::desktop
before 0:1.4.8-13.el3
0:1.4.8-13.el3
squirrelmail
Red Hat:enterprise_linux:3::es
before 0:1.4.8-13.el3
0:1.4.8-13.el3
squirrelmail
Red Hat:enterprise_linux:3::ws
before 0:1.4.8-13.el3
0:1.4.8-13.el3
squirrelmail
Red Hat:enterprise_linux:4::as
before 0:1.4.8-5.el4_8.5
0:1.4.8-5.el4_8.5
squirrelmail
Red Hat:enterprise_linux:4::desktop
before 0:1.4.8-5.el4_8.5
0:1.4.8-5.el4_8.5
squirrelmail
Red Hat:enterprise_linux:4::es
before 0:1.4.8-5.el4_8.5
0:1.4.8-5.el4_8.5
squirrelmail
Red Hat:enterprise_linux:4::ws
before 0:1.4.8-5.el4_8.5
0:1.4.8-5.el4_8.5
squirrelmail
Red Hat:enterprise_linux:5::client_workstation
before 0:1.4.8-5.el5_3.7
0:1.4.8-5.el5_3.7
squirrelmail
Red Hat:enterprise_linux:5::server
before 0:1.4.8-5.el5_3.7
0:1.4.8-5.el5_3.7

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1581 is a medium vulnerability (CVSS 4.3) in Squirrelmail, published May 14, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.75%, the 77th percentile. Fixed in squirrelmail 2:1.4.9a-4.

References

Show 34 moreShow less
MoveEnter Open