Every CVE Search/ Get API key

CVE-2009-1711

WebKit in Apple Safari before 4.0 does not properly initialize memory for Attr DOM objects, which...

9.3 HighFix available

WebKit in Apple Safari before 4.0 does not properly initialize memory for Attr DOM objects, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted HTML document.

Exploit likelihood

6.69%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

WebKit in Apple Safari before 4.0 does not properly initialize memory for Attr DOM objects, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted HTML document.

Record
CVE-2009-1711
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

WebKit in Apple Safari before 4.0 does not properly initialize memory for Attr DOM objects, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted HTML document.

Record
CVE-2009-1711
Updated
2026-11-02
EUVDEUVD-2009-1706 No score

WebKit in Apple Safari before 4.0 does not properly initialize memory for Attr DOM objects, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted HTML document.

Record
EUVD-2009-1706
Updated
2026-11-03
GitHub AdvisoriesGHSA-3j52-86hv-pq9m No score

WebKit in Apple Safari before 4.0 does not properly initialize memory for Attr DOM objects, which...

WebKit in Apple Safari before 4.0 does not properly initialize memory for Attr DOM objects, which allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted HTML document.

Record
GHSA-3j52-86hv-pq9m
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
webkit
Debian:5.0
before 1.0.1-4+lenny2, plus listed versions
1.0.1-4
1.0.1-4+lenny2
qt4-x11
Debian:5.0
before 4.4.3-1+lenny1, plus listed versions
4.4.3-1
4.4.3-1+lenny1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-1711 is a high vulnerability (CVSS 9.3) in Apple Safari, published June 10, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.69%, the 93rd percentile. Fixed in webkit 1.0.1-4+lenny2.

References

Show 13 moreShow less
MoveEnter Open