CVE-2009-2415
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute...
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute arbitrary code via vectors involving length attributes that trigger heap-based buffer overflows.
Exploit likelihood
What each source reports
NVD Score used
10.0
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute arbitrary code via vectors involving length attributes that trigger heap-based buffer overflows.
- Record
CVE-2009-2415- CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-189
- Updated
- 2026-11-02
CVE List No score
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute arbitrary code via vectors involving length attributes that trigger heap-based buffer overflows.
- Record
CVE-2009-2415- Updated
- 2026-11-02
EUVDEUVD-2009-2411 No score
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute arbitrary code via vectors involving length attributes that trigger heap-based buffer overflows.
- Record
EUVD-2009-2411- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4r9m-gmj4-v54c No score
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute...
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute arbitrary code via vectors involving length attributes that trigger heap-based buffer overflows.
- Record
GHSA-4r9m-gmj4-v54c- Updated
- 2026-11-02
OSV No score
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute arbitrary code via vectors involving length attributes that trigger heap-based buffer overflows.
- Record
CVE-2009-2415- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-2415 No score
Multiple integer overflows in memcached 1.1.12 and 1.2.2 allow remote attackers to execute arbitrary code via vectors involving length attributes that trigger heap-based buffer overflows.
- Record
DEBIAN-CVE-2009-2415- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
memcachedDebian:12 |
before 1.4.1-1 | 1.4.1-1 |
memcachedDebian:13 |
before 1.4.1-1 | 1.4.1-1 |
memcachedDebian:14 |
before 1.4.1-1 | 1.4.1-1 |
memcachedDebian:4.0 |
before 1.1.12-1+etch1, plus listed versions 1.1.12-1 |
1.1.12-1+etch1 |
memcachedDebian:5.0 |
before 1.2.2-1+lenny1, plus listed versions 1.2.2-1 |
1.2.2-1+lenny1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-2415 is a high vulnerability (CVSS 10.0) in Memcachedb Memcached, published August 7, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.62%, the 93rd percentile. Fixed in memcached 1.4.1-1.