Every CVE Search/ Get API key

CVE-2009-2431

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote...

5.0 MediumFix available

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote attackers to obtain sensitive information by reading the HTML source.

Exploit likelihood

2.87%Up 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote attackers to obtain sensitive information by reading the HTML source.

Record
CVE-2009-2431
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote attackers to obtain sensitive information by reading the HTML source.

Record
CVE-2009-2431
Updated
2026-11-02
EUVDEUVD-2009-2426 No score

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote attackers to obtain sensitive information by reading the HTML source.

Record
EUVD-2009-2426
Updated
2026-11-03
GitHub AdvisoriesGHSA-9354-f967-7fw8 No score

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote...

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote attackers to obtain sensitive information by reading the HTML source.

Record
GHSA-9354-f967-7fw8
Weakness
CWE-20
Updated
2026-11-02
OSV No score

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote attackers to obtain sensitive information by reading the HTML source.

Record
CVE-2009-2431
Updated
2026-11-02
OSVDEBIAN-CVE-2009-2431 No score

WordPress 2.7.1 places the username of a post's author in an HTML comment, which allows remote attackers to obtain sensitive information by reading the HTML source.

Record
DEBIAN-CVE-2009-2431
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 2.8.3-1
2.8.3-1
wordpress
Debian:13
before 2.8.3-1
2.8.3-1
wordpress
Debian:14
before 2.8.3-1
2.8.3-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-2431 is a medium vulnerability (CVSS 5.0) in Wordpress, published July 10, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.87%, the 86th percentile. Fixed in wordpress 2.8.3-1.

References

MoveEnter Open