CVE-2009-2658
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite...
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
Exploit likelihood
What each source reports
NVD Score used
7.5
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
- Record
CVE-2009-2658- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
- Record
CVE-2009-2658- Updated
- 2026-11-02
EUVDEUVD-2009-2652 No score
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
- Record
EUVD-2009-2652- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hcc5-4c4w-p9qg No score
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite...
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
- Record
GHSA-hcc5-4c4w-p9qg- Weakness
- CWE-22
- Updated
- 2026-11-02
OSV No score
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
- Record
CVE-2009-2658- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-2658 No score
Directory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
- Record
DEBIAN-CVE-2009-2658- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zncDebian:12 |
before 0.074-1 | 0.074-1 |
zncDebian:13 |
before 0.074-1 | 0.074-1 |
zncDebian:14 |
before 0.074-1 | 0.074-1 |
zncDebian:4.0 |
before 0.045-3+etch3, plus listed versions 0.045-30.045-3+etch10.045-3+etch2 |
0.045-3+etch3 |
zncDebian:5.0 |
before 0.058-2+lenny3, plus listed versions 0.058-20.058-2+lenny10.058-2+lenny2 |
0.058-2+lenny3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-2658 is a high vulnerability (CVSS 7.5) in Znc, published August 2, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.92%, the 87th percentile. Fixed in znc 0.074-1.