Every CVE Search/ Get API key

CVE-2009-2660

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute...

6.8 MediumFix available

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute arbitrary code via images containing large width and height values that trigger a heap-based buffer overflow, related to (1) crafted GIF files (gifread.c) and (2) crafted JPEG files (jpegread.c), a different vulnerability than CVE-2009-2295.

Exploit likelihood

3.55%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute arbitrary code via images containing large width and height values that trigger a heap-based buffer overflow, related to (1) crafted GIF files (gifread.c) and (2) crafted JPEG files (jpegread.c), a different vulnerability than CVE-2009-2295.

Record
CVE-2009-2660
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute arbitrary code via images containing large width and height values that trigger a heap-based buffer overflow, related to (1) crafted GIF files (gifread.c) and (2) crafted JPEG files (jpegread.c), a different vulnerability than CVE-2009-2295.

Record
CVE-2009-2660
Updated
2026-11-02
EUVDEUVD-2009-2653 No score

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute arbitrary code via images containing large width and height values that trigger a heap-based buffer overflow, related to (1) crafted GIF files (gifread.c) and (2) crafted JPEG files (jpegread.c), a different vulnerability than CVE-2009-2295.

Record
EUVD-2009-2653
Updated
2026-11-03
GitHub AdvisoriesGHSA-jv8p-6h4c-vx58 No score

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute...

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute arbitrary code via images containing large width and height values that trigger a heap-based buffer overflow, related to (1) crafted GIF files (gifread.c) and (2) crafted JPEG files (jpegread.c), a different vulnerability than CVE-2009-2295.

Record
GHSA-jv8p-6h4c-vx58
Updated
2026-11-02
OSV No score

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute arbitrary code via images containing large width and height values that trigger a heap-based buffer overflow, related to (1) crafted GIF files (gifread.c) and (2) crafted JPEG files (jpegread.c), a different vulnerability than CVE-2009-2295.

Record
CVE-2009-2660
Updated
2026-11-02
OSVDEBIAN-CVE-2009-2660 No score

Multiple integer overflows in CamlImages 2.2 might allow context-dependent attackers to execute arbitrary code via images containing large width and height values that trigger a heap-based buffer overflow, related to (1) crafted GIF files (gifread.c) and (2) crafted JPEG files (jpegread.c), a different vulnerability than CVE-2009-2295.

Record
DEBIAN-CVE-2009-2660
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
advi
Debian:12
before 1.6.0-15
1.6.0-15
advi
Debian:13
before 1.6.0-15
1.6.0-15
advi
Debian:14
before 1.6.0-15
1.6.0-15
camlimages
Debian:12
before 1:3.0.1-3
1:3.0.1-3
camlimages
Debian:13
before 1:3.0.1-3
1:3.0.1-3
camlimages
Debian:14
before 1:3.0.1-3
1:3.0.1-3
camlimages
Debian:4.0
before 2.20-8+etch2, plus listed versions
2.20-82.20-8+etch1
2.20-8+etch2
camlimages
Debian:5.0
before 1:2.2.0-4+lenny2, plus listed versions
1:2.2.0-41:2.2.0-4+lenny1
1:2.2.0-4+lenny2
camlimages
Debian:4.0
From an advisory covering 2 CVEs
before 2.20-8+etch3, plus listed versions
2.20-82.20-8+etch12.20-8+etch2
2.20-8+etch3
camlimages
Debian:5.0
From an advisory covering 2 CVEs
before 1:2.2.0-4+lenny3, plus listed versions
1:2.2.0-41:2.2.0-4+lenny11:2.2.0-4+lenny2
1:2.2.0-4+lenny3
advi
Debian:4.0
From an advisory covering 3 CVEs
before 1.6.0-12+etch2, plus listed versions
1.6.0-12
1.6.0-12+etch2
advi
Debian:5.0
From an advisory covering 3 CVEs
before 1.6.0-13+lenny2, plus listed versions
1.6.0-13
1.6.0-13+lenny2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-2660 is a medium vulnerability (CVSS 6.8) in Jun Furuse Camlimages, published August 4, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.55%, the 89th percentile. Fixed in advi 1.6.0-15.

References

Show 10 moreShow less
MoveEnter Open