CVE-2009-2943
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly...
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
Exploit likelihood
What each source reports
NVD Score used
7.5
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
- Record
CVE-2009-2943- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
- Record
CVE-2009-2943- Updated
- 2026-11-02
EUVDEUVD-2009-2930 No score
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
- Record
EUVD-2009-2930- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vvfr-p62m-9frc No score
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly...
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
- Record
GHSA-vvfr-p62m-9frc- Updated
- 2026-11-02
OSV No score
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
- Record
CVE-2009-2943- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-2943 No score
The postgresql-ocaml bindings 1.5.4, 1.7.0, and 1.12.1 for PostgreSQL libpq do not properly support the PQescapeStringConn function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
- Record
DEBIAN-CVE-2009-2943- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
postgresql-ocamlDebian:12 |
before 1.12.1-1 | 1.12.1-1 |
postgresql-ocamlDebian:13 |
before 1.12.1-1 | 1.12.1-1 |
postgresql-ocamlDebian:14 |
before 1.12.1-1 | 1.12.1-1 |
postgresql-ocamlDebian:4.0 |
before 1.5.4-2+etch1, plus listed versions 1.5.4-2 |
1.5.4-2+etch1 |
postgresql-ocamlDebian:5.0 |
before 1.7.0-3+lenny1, plus listed versions 1.7.0-3 |
1.7.0-3+lenny1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-2943 is a high vulnerability (CVSS 7.5) in Ocaml Postgresql-ocaml, published October 14, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in postgresql-ocaml 1.12.1-1.