CVE-2009-3617
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in...
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
Exploit likelihood
What each source reports
NVD Score used
7.6
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-3617- CVSS 2.0
- 7.6 High
AV:N/AC:H/Au:N/C:C/I:C/A:C - Weakness
- CWE-134
- Updated
- 2026-11-02
CVE List No score
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-3617- Updated
- 2026-11-02
EUVDEUVD-2009-3598 No score
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
- Record
EUVD-2009-3598- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m6c3-p3rg-chxv No score
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in...
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
- Record
GHSA-m6c3-p3rg-chxv- Weakness
- CWE-134
- Updated
- 2026-11-02
OSV No score
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
- Record
CVE-2009-3617- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-3617 No score
Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
- Record
DEBIAN-CVE-2009-3617- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10060-1 No score
aria2-1.29.0-1.1 on GA media
These are all security issues fixed in the aria2-1.29.0-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10060-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
aria2Debian:12 |
before 1.6.2-1 | 1.6.2-1 |
aria2Debian:13 |
before 1.6.2-1, plus listed versions 0.10.1-10.10.2+1-10.11.0-10.11.2-10.11.3-1 Show 16 moreShow less0.12.0-10.12.1-10.13.1+1-10.14.0-10.14.0-1+lenny10.14.0-1+lenny20.7.3-10.8.0-10.8.1-10.9.0-11.0.1-11.1.2-11.2.0-11.3.0-11.3.2-11.4.1-1 |
1.6.2-1 |
aria2Debian:14 |
before 1.6.2-1, plus listed versions 0.10.1-10.10.2+1-10.11.0-10.11.2-10.11.3-1 Show 16 moreShow less0.12.0-10.12.1-10.13.1+1-10.14.0-10.14.0-1+lenny10.14.0-1+lenny20.7.3-10.8.0-10.8.1-10.9.0-11.0.1-11.1.2-11.2.0-11.3.0-11.3.2-11.4.1-1 |
1.6.2-1 |
aria2openSUSE:Tumbleweed |
before 1.29.0-1.1 | 1.29.0-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-3617 is a high vulnerability (CVSS 7.6) in Tatsuhiro Tsujikawa Aria2, published October 20, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.89%, the 92nd percentile. Fixed in aria2 1.6.2-1.
References
fedorahosted.org/rel-eng/ticket/2495
aria2.svn.sourceforge.net/viewvc/aria2/trunk/src/AbstractCommand.cc?r1=1539&r2=1572
vupen.com/english/advisories/2009/2960
marc.info?l=oss-security&m=125568632528906&w=2
bugzilla.redhat.com/show_bug.cgi?id=529342
secunia.com/advisories/31732