CVE-2009-3629
TYPO3 Backend vulnerable to Cross-site Scripting
Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
3.5
Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2009-3629- CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2009-3629- Updated
- 2026-11-02
EUVDEUVD-2022-3923 No score
Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2022-3923- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g857-p997-wx7w No score
TYPO3 Backend vulnerable to Cross-site Scripting
Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-g857-p997-wx7w- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-g857-p997-wx7w No score
TYPO3 Backend vulnerable to Cross-site Scripting
Multiple cross-site scripting (XSS) vulnerabilities in the Backend subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-g857-p997-wx7w- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cms-backendPackagist |
through 4.0.13 | None known |
typo3/cms-backendPackagist |
4.1.0 up to 4.1.13 | 4.1.13 |
typo3/cms-backendPackagist |
4.2.0 up to 4.2.10 | 4.2.10 |
typo3/cms-backendPackagist |
4.3alpha1 up to 4.3beta2 | 4.3beta2 |
typo3-srcDebian:4.0 From an advisory covering 9 CVEs |
before 4.0.2+debian-9 | 4.0.2+debian-9 |
typo3-srcDebian:5.0 From an advisory covering 9 CVEs |
before 4.2.5-1+lenny2, plus listed versions 4.2.5-14.2.5-1+lenny1 |
4.2.5-1+lenny2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-3629 is a low vulnerability (CVSS 3.5) in Typo3, published November 2, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.54%, the 74th percentile. Fixed in typo3/cms-backend 4.1.13.