Every CVE Search/ Get API key

CVE-2009-3636

Typo3 API Install Tool vulnerable to Cross-site Scripting

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Exploit likelihood

1.96%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Record
CVE-2009-3636
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Record
CVE-2009-3636
Updated
2026-11-02
EUVDEUVD-2022-3521 No score

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Record
EUVD-2022-3521
Updated
2026-11-03
GitHub AdvisoriesGHSA-c73w-4rcj-2622 No score

Typo3 API Install Tool vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Record
GHSA-c73w-4rcj-2622
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-c73w-4rcj-2622 No score

Typo3 API Install Tool vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Record
GHSA-c73w-4rcj-2622
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2009-3636 No score

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Record
UBUNTU-CVE-2009-3636
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typo3/cms-install
Packagist
through 4.0.13 None known
typo3/cms-install
Packagist
4.1.0 up to 4.1.13
4.1.13
typo3/cms-install
Packagist
4.2.0 up to 4.2.10
4.2.10
typo3/cms-install
Packagist
4.3alpha1 up to 4.3beta2
4.3beta2
typo3-src
Debian:4.0
From an advisory covering 9 CVEs
before 4.0.2+debian-9
4.0.2+debian-9
typo3-src
Debian:5.0
From an advisory covering 9 CVEs
before 4.2.5-1+lenny2, plus listed versions
4.2.5-14.2.5-1+lenny1
4.2.5-1+lenny2

History

History
RecordedChangedSources
affected, facts
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-3636 is a medium vulnerability (CVSS 4.3) in Typo3, published November 2, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in typo3/cms-install 4.1.13.

References

Show 7 moreShow less
MoveEnter Open