CVE-2009-3891
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6...
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML via the s parameter (aka the selection variable).
Exploit likelihood
What each source reports
NVD Score used
3.5
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML via the s parameter (aka the selection variable).
- Record
CVE-2009-3891- CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML via the s parameter (aka the selection variable).
- Record
CVE-2009-3891- Updated
- 2026-11-02
EUVDEUVD-2009-3862 No score
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML via the s parameter (aka the selection variable).
- Record
EUVD-2009-3862- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-8wqr-ch99-7r8g No score
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6...
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML via the s parameter (aka the selection variable).
- Record
GHSA-8wqr-ch99-7r8g- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML via the s parameter (aka the selection variable).
- Record
CVE-2009-3891- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-3891 No score
Cross-site scripting (XSS) vulnerability in wp-admin/press-this.php in WordPress before 2.8.6 allows remote authenticated users to inject arbitrary web script or HTML via the s parameter (aka the selection variable).
- Record
DEBIAN-CVE-2009-3891- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-3891 is a low vulnerability (CVSS 3.5) in Wordpress, published November 17, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.18%, the 82nd percentile. Fixed in wordpress 2.8.6-1.
References
secunia.com/advisories/37332
openwall.com/lists/oss-security/2009/11/16/1
wordpress.org/development/2009/11/wordpress-2-8-6-security-release
osvdb.org/59959
openwall.com/lists/oss-security/2009/11/15/3
core.trac.wordpress.org/ticket/11119
Show 6 moreShow less
core.trac.wordpress.org/attachment/ticket/11119/press-this-xss-bug-11-10-2009.patch
openwall.com/lists/oss-security/2009/11/15/2
core.trac.wordpress.org/attachment/ticket/11119/press-this.002.diff
nvd.nist.gov/vuln/detail/CVE-2009-3891
github.com/advisories/GHSA-8wqr-ch99-7r8g
security-tracker.debian.org/tracker/CVE-2009-3891