Every CVE Search/ Get API key

CVE-2009-4015

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote...

7.5 HighFix available

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.

Exploit likelihood

3.90%Up 1.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.

Record
CVE-2009-4015
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.

Record
CVE-2009-4015
Updated
2026-11-02
EUVDEUVD-2009-3986 No score

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.

Record
EUVD-2009-3986
Updated
2026-11-03
GitHub AdvisoriesGHSA-f866-mhcw-m7pp No score

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote...

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.

Record
GHSA-f866-mhcw-m7pp
Weakness
CWE-89
Updated
2026-11-02
OSV No score

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.

Record
CVE-2009-4015
Updated
2026-11-02
OSVDEBIAN-CVE-2009-4015 No score

Lintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.

Record
DEBIAN-CVE-2009-4015
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lintian
Debian:12
before 2.3.2
2.3.2
lintian
Debian:13
before 2.3.2
2.3.2
lintian
Debian:14
before 2.3.2
2.3.2
lintian
Debian:4.0
From an advisory covering 3 CVEs
before 1.23.28+etch1, plus listed versions
1.23.28
1.23.28+etch1
lintian
Debian:5.0
From an advisory covering 3 CVEs
before 1.24.2.1+lenny1, plus listed versions
1.24.2.1
1.24.2.1+lenny1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4015 is a high vulnerability (CVSS 7.5) in Debian Lintian, published January 27, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.90%, the 90th percentile. Fixed in lintian 2.3.2.

References

Show 8 moreShow less
MoveEnter Open