CVE-2009-4070
SQL injection vulnerability in GForge 4.5.14, 4.7.3, and possibly other versions allows remote...
SQL injection vulnerability in GForge 4.5.14, 4.7.3, and possibly other versions allows remote attackers to execute arbitrary SQL commands via unknown vectors.
Exploit likelihood
What each source reports
NVD Score used
7.5
SQL injection vulnerability in GForge 4.5.14, 4.7.3, and possibly other versions allows remote attackers to execute arbitrary SQL commands via unknown vectors.
- Record
CVE-2009-4070- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
SQL injection vulnerability in GForge 4.5.14, 4.7.3, and possibly other versions allows remote attackers to execute arbitrary SQL commands via unknown vectors.
- Record
CVE-2009-4070- Updated
- 2026-11-02
EUVDEUVD-2009-4041 No score
SQL injection vulnerability in GForge 4.5.14, 4.7.3, and possibly other versions allows remote attackers to execute arbitrary SQL commands via unknown vectors.
- Record
EUVD-2009-4041- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3283-h39g-mw6m No score
SQL injection vulnerability in GForge 4.5.14, 4.7.3, and possibly other versions allows remote...
SQL injection vulnerability in GForge 4.5.14, 4.7.3, and possibly other versions allows remote attackers to execute arbitrary SQL commands via unknown vectors.
- Record
GHSA-3283-h39g-mw6m- Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gforgeDebian:4.0 |
before 4.5.14-22etch11, plus listed versions 4.5.14-224.5.14-22etch14.5.14-22etch104.5.14-22etch24.5.14-22etch3 Show 6 moreShow less4.5.14-22etch44.5.14-22etch54.5.14-22etch64.5.14-22etch74.5.14-22etch84.5.14-22etch9 |
4.5.14-22etch11 |
gforgeDebian:5.0 |
before 4.7~rc2-7lenny1, plus listed versions 4.7~rc2-7 |
4.7~rc2-7lenny1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-4070 is a high vulnerability (CVSS 7.5) in Gforge, published June 18, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.73%, the 77th percentile. Fixed in gforge 4.5.14-22etch11.