Every CVE Search/ Get API key

CVE-2009-4214

Moderate severity vulnerability that affects rails

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Exploit likelihood

3.02%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Record
CVE-2009-4214
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Record
CVE-2009-4214
Updated
2026-11-02
EUVDEUVD-2017-0207 No score

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Record
EUVD-2017-0207
Updated
2026-11-03
GitHub AdvisoriesGHSA-9p3v-wf2w-v29c No score

Moderate severity vulnerability that affects rails

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Record
GHSA-9p3v-wf2w-v29c
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Record
CVE-2009-4214
Updated
2026-11-02
OSVDEBIAN-CVE-2009-4214 No score

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Record
DEBIAN-CVE-2009-4214
Updated
2026-11-02
OSVGHSA-9p3v-wf2w-v29c No score

Moderate severity vulnerability that affects rails

Cross-site scripting (XSS) vulnerability in the strip_tags function in Ruby on Rails before 2.2.s, and 2.3.x before 2.3.5, allows remote attackers to inject arbitrary web script or HTML via vectors involving non-printing ASCII characters, related to HTML::Tokenizer and actionpack/lib/action_controller/vendor/html-scanner/html/node.rb.

Record
GHSA-9p3v-wf2w-v29c
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rails
RubyGems
before 2.2.2
2.2.2
rails
RubyGems
2.3.0 up to 2.3.5
2.3.5
rails
Debian:12
before 2.2.3-2
2.2.3-2
rails
Debian:13
before 2.2.3-2
2.2.3-2
rails
Debian:14
before 2.2.3-2
2.2.3-2
rails
Debian:5.0
From an advisory covering 2 CVEs
before 2.1.0-7+lenny0.2, plus listed versions
2.1.0-62.1.0-72.1.0-7+lenny0.1
2.1.0-7+lenny0.2
rails
Debian:6.0
From an advisory covering 4 CVEs
before 2.3.5-1.2+squeeze1, plus listed versions
2.3.5-1.22.3.5-1.2+squeeze0.1
2.3.5-1.2+squeeze1
rails
Debian:5.0
From an advisory covering 4 CVEs
before 2.1.0-7+lenny1, plus listed versions
2.1.0-62.1.0-72.1.0-7+lenny0.12.1.0-7+lenny0.2
2.1.0-7+lenny1
rails
RubyGems
before 2.2.2, plus listed versions
0.10.00.10.10.11.00.11.10.12.0
Show 39 moreShow less
0.12.10.13.00.13.10.14.10.14.20.14.30.14.40.8.00.8.50.9.00.9.10.9.20.9.30.9.40.9.4.10.9.51.0.01.1.01.1.11.1.21.1.31.1.41.1.51.1.61.2.01.2.11.2.21.2.31.2.41.2.51.2.62.0.02.0.12.0.22.0.42.0.52.1.02.1.12.1.2
2.2.2
rails
RubyGems
2.3.0 up to 2.3.5, plus listed versions
2.3.22.3.32.3.4
2.3.5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4214 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published December 7, 2009. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.02%, the 87th percentile. Fixed in rails 2.2.2.

References

Show 14 moreShow less
MoveEnter Open