CVE-2009-4427
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to...
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the cmd parameter.
Exploit likelihood
What each source reports
NVD Score used
7.5
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the cmd parameter.
- Record
CVE-2009-4427- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the cmd parameter.
- Record
CVE-2009-4427- Updated
- 2026-11-02
EUVDEUVD-2009-4394 No score
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the cmd parameter.
- Record
EUVD-2009-4394- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5jx8-6jmm-pj5j No score
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to...
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the cmd parameter.
- Record
GHSA-5jx8-6jmm-pj5j- Weakness
- CWE-22
- Updated
- 2026-11-02
OSV No score
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the cmd parameter.
- Record
CVE-2009-4427- Updated
- 2026-11-02
OSVDEBIAN-CVE-2009-4427 No score
Directory traversal vulnerability in cmd.php in phpLDAPadmin 1.1.0.5 allows remote attackers to include and execute arbitrary local files via a .. (dot dot) in the cmd parameter.
- Record
DEBIAN-CVE-2009-4427- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpldapadminDebian:12 |
before 1.1.0.7-1.1 | 1.1.0.7-1.1 |
phpldapadminDebian:13 |
before 1.1.0.7-1.1 | 1.1.0.7-1.1 |
phpldapadminDebian:14 |
before 1.1.0.7-1.1 | 1.1.0.7-1.1 |
phpldapadminDebian:5.0 |
before 1.1.0.5-6+lenny1, plus listed versions 1.1.0.5-6 |
1.1.0.5-6+lenny1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | phpLDAPadmin - Local File Inclusion | 2009-12-10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2009-4427 is a high vulnerability (CVSS 7.5) in Phpldapadmin Project Phpldapadmin, published December 28, 2009. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 10.00%, the 95th percentile. Fixed in phpldapadmin 1.1.0.7-1.1.