Every CVE Search/ Get API key

CVE-2009-4637

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute...

10.0 HighPublic exploitFix available

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a stack-based buffer overflow.

Exploit likelihood

17.4%Down 17.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 10.0

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a stack-based buffer overflow.

Record
CVE-2009-4637
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a stack-based buffer overflow.

Record
CVE-2009-4637
Updated
2026-11-02
EUVDEUVD-2009-4602 No score

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a stack-based buffer overflow.

Record
EUVD-2009-4602
Updated
2026-11-03
GitHub AdvisoriesGHSA-v8f9-pj55-fp23 No score

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute...

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a stack-based buffer overflow.

Record
GHSA-v8f9-pj55-fp23
Weakness
CWE-119
Updated
2026-11-02
OSV No score

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a stack-based buffer overflow.

Record
CVE-2009-4637
Updated
2026-11-02
OSVDEBIAN-CVE-2009-4637 No score

FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a stack-based buffer overflow.

Record
DEBIAN-CVE-2009-4637
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Debian:12
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:13
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg
Debian:14
before 4:0.5+svn20090706-3
4:0.5+svn20090706-3
ffmpeg-debian
Debian:5.0
From an advisory covering 9 CVEs
before 0.svn20080206-18+lenny1, plus listed versions
0.svn20080206-160.svn20080206-170.svn20080206-17+lenny10.svn20080206-18
0.svn20080206-18+lenny1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBFFmpeg 0.5 - Multiple Remote Vulnerabilities2009-09-21

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4637 is a high vulnerability (CVSS 10.0) in Ffmpeg, published February 10, 2010. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 17.4%, the 97th percentile. Fixed in ffmpeg 4:0.5+svn20090706-3.

References

Show 6 moreShow less
MoveEnter Open