Every CVE Search/ Get API key

CVE-2009-4897

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to...

9.3 HighFix available

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Exploit likelihood

6.63%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Record
CVE-2009-4897
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Record
CVE-2009-4897
Updated
2026-11-02
EUVDEUVD-2009-4860 No score

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Record
EUVD-2009-4860
Updated
2026-11-03
GitHub AdvisoriesGHSA-53pw-2446-9fc8 No score

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to...

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Record
GHSA-53pw-2446-9fc8
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Record
CVE-2009-4897
Updated
2026-11-02
OSVDEBIAN-CVE-2009-4897 No score

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Record
DEBIAN-CVE-2009-4897
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ghostscript
Debian:12
before 8.70~dfsg-1
8.70~dfsg-1
ghostscript
Debian:13
before 8.70~dfsg-1
8.70~dfsg-1
ghostscript
Debian:14
before 8.70~dfsg-1
8.70~dfsg-1
ghostscript
Debian:5.0
From an advisory covering 2 CVEs
before 8.62.dfsg.1-3.2lenny5, plus listed versions
8.62.dfsg.1-3.2lenny08.62.dfsg.1-3.2lenny18.62.dfsg.1-3.2lenny28.62.dfsg.1-3.2lenny4
8.62.dfsg.1-3.2lenny5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2009-4897 is a high vulnerability (CVSS 9.3) in Artifex Afpl Ghostscript, published July 22, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.63%, the 93rd percentile. Fixed in ghostscript 8.70~dfsg-1.

References

Show 7 moreShow less
MoveEnter Open