Every CVE Search/ Get API key

CVE-2010-0186

Cross-domain vulnerability in Adobe Flash Player before 10.0.45.2, Adobe AIR before 1.5.3.9130,...

6.8 MediumFix available

Cross-domain vulnerability in Adobe Flash Player before 10.0.45.2, Adobe AIR before 1.5.3.9130, and Adobe Reader and Acrobat 8.x before 8.2.1 and 9.x before 9.3.1 allows remote attackers to bypass intended sandbox restrictions and make cross-domain requests via unspecified vectors.

Exploit likelihood

4.40%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Cross-domain vulnerability in Adobe Flash Player before 10.0.45.2, Adobe AIR before 1.5.3.9130, and Adobe Reader and Acrobat 8.x before 8.2.1 and 9.x before 9.3.1 allows remote attackers to bypass intended sandbox restrictions and make cross-domain requests via unspecified vectors.

Record
CVE-2010-0186
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Cross-domain vulnerability in Adobe Flash Player before 10.0.45.2, Adobe AIR before 1.5.3.9130, and Adobe Reader and Acrobat 8.x before 8.2.1 and 9.x before 9.3.1 allows remote attackers to bypass intended sandbox restrictions and make cross-domain requests via unspecified vectors.

Record
CVE-2010-0186
Updated
2026-11-02
EUVDEUVD-2010-0217 No score

Cross-domain vulnerability in Adobe Flash Player before 10.0.45.2, Adobe AIR before 1.5.3.9130, and Adobe Reader and Acrobat 8.x before 8.2.1 and 9.x before 9.3.1 allows remote attackers to bypass intended sandbox restrictions and make cross-domain requests via unspecified vectors.

Record
EUVD-2010-0217
Updated
2026-11-03
GitHub AdvisoriesGHSA-2pfw-x8hw-9289 No score

Cross-domain vulnerability in Adobe Flash Player before 10.0.45.2, Adobe AIR before 1.5.3.9130,...

Cross-domain vulnerability in Adobe Flash Player before 10.0.45.2, Adobe AIR before 1.5.3.9130, and Adobe Reader and Acrobat 8.x before 8.2.1 and 9.x before 9.3.1 allows remote attackers to bypass intended sandbox restrictions and make cross-domain requests via unspecified vectors.

Record
GHSA-2pfw-x8hw-9289
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-plugin
Red Hat:rhel_extras:5::client
From an advisory covering 2 CVEs
before 0:10.0.45.2-1.el5
0:10.0.45.2-1.el5
flash-plugin
Red Hat:rhel_extras:5::server
From an advisory covering 2 CVEs
before 0:10.0.45.2-1.el5
0:10.0.45.2-1.el5
flash-plugin
Red Hat:rhel_extras:3
before 0:9.0.262.0-1.el3.with.oss
0:9.0.262.0-1.el3.with.oss
flash-plugin
Red Hat:rhel_extras:4
before 0:9.0.262.0-1.el4
0:9.0.262.0-1.el4
acroread
Red Hat:rhel_extras:4
From an advisory covering 2 CVEs
before 0:9.3.1-1.el4
0:9.3.1-1.el4
acroread-plugin
Red Hat:rhel_extras:4
From an advisory covering 2 CVEs
before 0:9.3.1-1.el4
0:9.3.1-1.el4
acroread
Red Hat:rhel_extras:5::client
From an advisory covering 2 CVEs
before 0:9.3.1-1.el5
0:9.3.1-1.el5
acroread-plugin
Red Hat:rhel_extras:5::client
From an advisory covering 2 CVEs
before 0:9.3.1-1.el5
0:9.3.1-1.el5
acroread
Red Hat:rhel_extras:5::server
From an advisory covering 2 CVEs
before 0:9.3.1-1.el5
0:9.3.1-1.el5
acroread-plugin
Red Hat:rhel_extras:5::server
From an advisory covering 2 CVEs
before 0:9.3.1-1.el5
0:9.3.1-1.el5

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-0186 is a medium vulnerability (CVSS 6.8) in Adobe Acrobat, published February 15, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.40%, the 91st percentile. Fixed in flash-plugin 0:9.0.262.0-1.el3.with.oss.

References

Show 37 moreShow less
MoveEnter Open