CVE-2010-0289
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl...
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
Exploit likelihood
What each source reports
NVD Score used
6.8
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
- Record
CVE-2010-0289- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
- Record
CVE-2010-0289- Updated
- 2026-11-02
EUVDEUVD-2010-0320 No score
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
- Record
EUVD-2010-0320- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xw78-vx8x-r728 No score
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl...
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
- Record
GHSA-xw78-vx8x-r728- Weakness
- CWE-352
- Updated
- 2026-11-02
OSV No score
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
- Record
CVE-2010-0289- Updated
- 2026-11-02
OSVDEBIAN-CVE-2010-0289 No score
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
- Record
DEBIAN-CVE-2010-0289- Updated
- 2026-11-02
OSVUBUNTU-CVE-2010-0289 No score
Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.
- Record
UBUNTU-CVE-2010-0289- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dokuwikiDebian:12 |
before 0.0.20090214b-3.1 | 0.0.20090214b-3.1 |
dokuwikiDebian:13 |
before 0.0.20090214b-3.1 | 0.0.20090214b-3.1 |
dokuwikiDebian:14 |
before 0.0.20090214b-3.1 | 0.0.20090214b-3.1 |
dokuwikiDebian:5.0 From an advisory covering 3 CVEs |
before 0.0.20080505-4+lenny1, plus listed versions 0.0.20080505-4 |
0.0.20080505-4+lenny1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2010-0289 is a medium vulnerability (CVSS 6.8) in Dokuwiki, published January 22, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in dokuwiki 0.0.20090214b-3.1.
References
bugs.splitbrain.org/index.php?do=details&task_id=1853
lists.fedoraproject.org/pipermail/package-announce/2010-February/034729.html
security.gentoo.org/glsa/glsa-201301-07.xml
splitbrain.org/blog/2010-01/17-dokuwiki-security
freshmeat.net/projects/dokuwiki/tags/security-fix
debian.org/security/2010/dsa-1976
Show 8 moreShow less
osvdb.org/61708
lists.fedoraproject.org/pipermail/package-announce/2010-February/034831.html
secunia.com/advisories/38205
nvd.nist.gov/vuln/detail/CVE-2010-0289
github.com/advisories/GHSA-xw78-vx8x-r728
security-tracker.debian.org/tracker/CVE-2010-0289
ubuntu.com/security/CVE-2010-0289
cve.org/CVERecord?id=CVE-2010-0289