Every CVE Search/ Get API key

CVE-2010-0402

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows...

6.5 MediumFix available

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted in-game command.

Exploit likelihood

2.22%Down 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted in-game command.

Record
CVE-2010-0402
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted in-game command.

Record
CVE-2010-0402
Updated
2026-11-02
EUVDEUVD-2010-0433 No score

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted in-game command.

Record
EUVD-2010-0433
Updated
2026-11-03
GitHub AdvisoriesGHSA-m5pw-gjvh-jgrh No score

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows...

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted in-game command.

Record
GHSA-m5pw-gjvh-jgrh
Weakness
CWE-94
Updated
2026-11-02
OSV No score

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted in-game command.

Record
CVE-2010-0402
Updated
2026-11-02
OSVDEBIAN-CVE-2010-0402 No score

OpenTTD before 1.0.1 does not properly validate index values of certain items, which allows remote authenticated users to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted in-game command.

Record
DEBIAN-CVE-2010-0402
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openttd
Debian:12
before 1.0.1-1
1.0.1-1
openttd
Debian:13
before 1.0.1-1
1.0.1-1
openttd
Debian:14
before 1.0.1-1
1.0.1-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-0402 is a medium vulnerability (CVSS 6.5) in Openttd, published May 4, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.22%, the 82nd percentile. Fixed in openttd 1.0.1-1.

References

MoveEnter Open