Every CVE Search/ Get API key

CVE-2010-0629

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka...

6.5 MediumFix available

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote authenticated users to cause a denial of service (daemon crash) via a request from a kadmin client that sends an invalid API version number.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

5.47%Up 2.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote authenticated users to cause a denial of service (daemon crash) via a request from a kadmin client that sends an invalid API version number.

Record
CVE-2010-0629
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote authenticated users to cause a denial of service (daemon crash) via a request from a kadmin client that sends an invalid API version number.

Record
CVE-2010-0629
Updated
2026-11-02
EUVDEUVD-2010-0660 No score

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote authenticated users to cause a denial of service (daemon crash) via a request from a kadmin client that sends an invalid API version number.

Record
EUVD-2010-0660
Updated
2026-11-03
GitHub AdvisoriesGHSA-6243-f9c4-77f4 6.5

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka...

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote authenticated users to cause a denial of service (daemon crash) via a request from a kadmin client that sends an invalid API version number.

Record
GHSA-6243-f9c4-77f4
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-416
Updated
2026-11-02
OSV 6.5

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote authenticated users to cause a denial of service (daemon crash) via a request from a kadmin client that sends an invalid API version number.

Record
CVE-2010-0629
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2010-0629 6.5

Use-after-free vulnerability in kadmin/server/server_stubs.c in kadmind in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote authenticated users to cause a denial of service (daemon crash) via a request from a kadmin client that sends an invalid API version number.

Record
DEBIAN-CVE-2010-0629
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
krb5
Debian:12
before 1.7+dfsg-1
1.7+dfsg-1
krb5
Debian:13
before 1.7+dfsg-1
1.7+dfsg-1
krb5
Debian:14
before 1.7+dfsg-1
1.7+dfsg-1
krb5
Debian:5.0
before 1.6.dfsg.4~beta1-5lenny3, plus listed versions
1.6.dfsg.4~beta1-51.6.dfsg.4~beta1-5lenny11.6.dfsg.4~beta1-5lenny2
1.6.dfsg.4~beta1-5lenny3
krb5
Red Hat:enterprise_linux:5::client_workstation
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-debuginfo
Red Hat:enterprise_linux:5::client_workstation
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-devel
Red Hat:enterprise_linux:5::client_workstation
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-server
Red Hat:enterprise_linux:5::client_workstation
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5
Red Hat:enterprise_linux:5::client
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-debuginfo
Red Hat:enterprise_linux:5::client
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
Show 8 moreShow less
Affected packages
PackageAffectedFixed
krb5-libs
Red Hat:enterprise_linux:5::client
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-workstation
Red Hat:enterprise_linux:5::client
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5
Red Hat:enterprise_linux:5::server
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-debuginfo
Red Hat:enterprise_linux:5::server
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-devel
Red Hat:enterprise_linux:5::server
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-libs
Red Hat:enterprise_linux:5::server
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-server
Red Hat:enterprise_linux:5::server
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2
krb5-workstation
Red Hat:enterprise_linux:5::server
before 0:1.6.1-36.el5_5.2
0:1.6.1-36.el5_5.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-0629 is a medium vulnerability (CVSS 6.5) in Mit Kerberos 5, published April 7, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.47%, the 92nd percentile. Fixed in krb5 1.7+dfsg-1.

References

Show 23 moreShow less
MoveEnter Open