Every CVE Search/ Get API key

CVE-2010-0793

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service ...

7.5 HighFix available

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Exploit likelihood

3.81%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Record
CVE-2010-0793
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Record
CVE-2010-0793
Updated
2026-11-02
EUVDEUVD-2010-0819 No score

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Record
EUVD-2010-0819
Updated
2026-11-03
GitHub AdvisoriesGHSA-7w8g-7q9j-4m8v No score

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service ...

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Record
GHSA-7w8g-7q9j-4m8v
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Record
CVE-2010-0793
Updated
2026-11-02
OSVDEBIAN-CVE-2010-0793 No score

Buffer overflow in BarnOwl before 1.5.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted CC: header.

Record
DEBIAN-CVE-2010-0793
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
barnowl
Debian:12
before 1.5.1-1
1.5.1-1
barnowl
Debian:13
before 1.5.1-1
1.5.1-1
barnowl
Debian:14
before 1.5.1-1
1.5.1-1
barnowl
Debian:5.0
before 1.0.1-4+lenny1, plus listed versions
1.0.1-31.0.1-4
1.0.1-4+lenny1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-0793 is a high vulnerability (CVSS 7.5) in Barnowl, published March 16, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.81%, the 90th percentile. Fixed in barnowl 1.5.1-1.

References

MoveEnter Open