Every CVE Search/ Get API key

CVE-2010-1104

Moderate severity vulnerability that affects Zope2

4.3 MediumFix available

CVE-2010-1104 is a medium vulnerability (CVSS 4.3) in Zope, published March 25, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in zope2 2.8.12.

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Exploit likelihood

1.96%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Record
CVE-2010-1104
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Record
CVE-2010-1104
Updated
2026-11-02
EUVDEUVD-2018-0324 No score

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Record
EUVD-2018-0324
Updated
2026-11-03
GitHub AdvisoriesGHSA-v7q8-wvvh-c97p No score

Moderate severity vulnerability that affects Zope2

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Record
GHSA-v7q8-wvvh-c97p
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-v7q8-wvvh-c97p No score

Moderate severity vulnerability that affects Zope2

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Record
GHSA-v7q8-wvvh-c97p
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2026-765 No score

Moderate severity vulnerability that affects Zope2

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Record
PYSEC-2026-765
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zope2
PyPI
2.8.0 up to 2.8.12
2.8.12
zope2
PyPI
2.9.0 up to 2.9.12
2.9.12
zope2
PyPI
2.10.0 up to 2.10.11
2.10.11
zope2
PyPI
2.11.0 up to 2.11.6
2.11.6
zope2
PyPI
2.12.0 up to 2.12.3
2.12.3
zope2
PyPI
2.12.0 up to 2.12.3, plus listed versions
2.12.12.12.2
2.12.3
zope2
PyPI
2.8.0 up to 2.8.12, 2.9.0 up to 2.9.12, 2.10.0 up to 2.10.11, 2.11.0 up to 2.11.6, 2.12.0 up to 2.12.3, plus listed versions
2.12.12.12.2
2.8.122.9.122.10.112.11.62.12.3
conga
Red Hat:rhel_cluster:5
before 0:0.12.2-51.el5
0:0.12.2-51.el5
conga-debuginfo
Red Hat:rhel_cluster:5
before 0:0.12.2-51.el5
0:0.12.2-51.el5
luci
Red Hat:rhel_cluster:5
before 0:0.12.2-51.el5
0:0.12.2-51.el5
ricci
Red Hat:rhel_cluster:5
before 0:0.12.2-51.el5
0:0.12.2-51.el5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 17 moreShow less
MoveEnter Open