Every CVE Search/ Get API key

CVE-2010-1613

Moodle Session Fixation vulnerability

6.8 MediumFix available

Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for remote attackers to conduct session fixation attacks.

Exploit likelihood

1.81%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for remote attackers to conduct session fixation attacks.

Record
CVE-2010-1613
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-287
Updated
2026-11-02
CVE List No score

Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for remote attackers to conduct session fixation attacks.

Record
CVE-2010-1613
Updated
2026-11-02
EUVDEUVD-2010-1639 No score

Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for remote attackers to conduct session fixation attacks.

Record
EUVD-2010-1639
Updated
2026-11-03
GitHub AdvisoriesGHSA-j5rc-cr5w-vfg6 6.6

Moodle Session Fixation vulnerability

Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for remote attackers to conduct session fixation attacks.

Record
GHSA-j5rc-cr5w-vfg6
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-287, CWE-384
Updated
2026-11-02
OSVGHSA-j5rc-cr5w-vfg6 6.6

Moodle Session Fixation vulnerability

Moodle 1.8.x and 1.9.x before 1.9.8 does not enable the "Regenerate session id during login" setting by default, which makes it easier for remote attackers to conduct session fixation attacks.

Record
GHSA-j5rc-cr5w-vfg6
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-287, CWE-384
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
1.8.0 up to 1.9.8
1.9.8
moodle
Debian:5.0
From an advisory covering 13 CVEs
before 1.8.13-1, plus listed versions
1.8.2.dfsg-31.8.2.dfsg-3+lenny11.8.2.dfsg-3+lenny21.8.2.dfsg-3+lenny31.8.2.dfsg-4
Show 4 moreShow less
1.8.2.dfsg-51.8.2.dfsg-5.11.8.2.dfsg-61.8.2.dfsg-6.1
1.8.13-1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-1613 is a medium vulnerability (CVSS 6.8) in Moodle, published April 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.81%, the 78th percentile. Fixed in moodle/moodle 1.9.8.

References

MoveEnter Open