Every CVE Search/ Get API key

CVE-2010-1618

phpCAS client library and Moodle Cross-site Scripting vulnerability

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Exploit likelihood

1.81%Up 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Record
CVE-2010-1618
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Record
CVE-2010-1618
Updated
2026-11-02
EUVDEUVD-2022-2303 No score

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Record
EUVD-2022-2303
Updated
2026-11-03
GitHub AdvisoriesGHSA-45ch-hxgr-vx8j No score

phpCAS client library and Moodle Cross-site Scripting vulnerability

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Record
GHSA-45ch-hxgr-vx8j
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-45ch-hxgr-vx8j No score

phpCAS client library and Moodle Cross-site Scripting vulnerability

Cross-site scripting (XSS) vulnerability in the phpCAS client library before 1.1.0, as used in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8, allows remote attackers to inject arbitrary web script or HTML via a crafted URL, which is not properly handled in an error message.

Record
GHSA-45ch-hxgr-vx8j
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apereo/phpcas
Packagist
before 1.1.0
1.1.0
moodle/moodle
Packagist
1.8.0 up to 1.8.12
1.8.12
moodle/moodle
Packagist
1.9.0 up to 1.9.8
1.9.8
moodle
Debian:5.0
From an advisory covering 13 CVEs
before 1.8.13-1, plus listed versions
1.8.2.dfsg-31.8.2.dfsg-3+lenny11.8.2.dfsg-3+lenny21.8.2.dfsg-3+lenny31.8.2.dfsg-4
Show 4 moreShow less
1.8.2.dfsg-51.8.2.dfsg-5.11.8.2.dfsg-61.8.2.dfsg-6.1
1.8.13-1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-1618 is a medium vulnerability (CVSS 4.3) in Ja-sig Phpcas Client Library, published April 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.81%, the 78th percentile. Fixed in apereo/phpcas 1.1.0.

References

MoveEnter Open