Every CVE Search/ Get API key

CVE-2010-2170

Integer overflow in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR...

9.3 HighFix available

Integer overflow in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR before 2.0.2.12610, might allow attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2010-2181 and CVE-2010-2183.

Exploit likelihood

7.44%Up 2.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Integer overflow in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR before 2.0.2.12610, might allow attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2010-2181 and CVE-2010-2183.

Record
CVE-2010-2170
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR before 2.0.2.12610, might allow attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2010-2181 and CVE-2010-2183.

Record
CVE-2010-2170
Updated
2026-11-02
EUVDEUVD-2010-2186 No score

Integer overflow in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR before 2.0.2.12610, might allow attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2010-2181 and CVE-2010-2183.

Record
EUVD-2010-2186
Updated
2026-11-03
GitHub AdvisoriesGHSA-whpq-x3wf-fq4q No score

Integer overflow in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR...

Integer overflow in Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64, and Adobe AIR before 2.0.2.12610, might allow attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2010-2181 and CVE-2010-2183.

Record
GHSA-whpq-x3wf-fq4q
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-plugin
Red Hat:rhel_extras:5::client
before 0:10.1-2.el5
0:10.1-2.el5
flash-plugin
Red Hat:rhel_extras:5::server
before 0:10.1-2.el5
0:10.1-2.el5
flash-plugin
Red Hat:rhel_extras:3
before 0:9.0.277.0-1.el3.with.oss
0:9.0.277.0-1.el3.with.oss
flash-plugin
Red Hat:rhel_extras:4
before 0:9.0.277.0-1.el4
0:9.0.277.0-1.el4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-2170 is a high vulnerability (CVSS 9.3) in Adobe Air, published June 15, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.44%, the 94th percentile. Fixed in flash-plugin 0:10.1-2.el5.

References

Show 127 moreShow less
MoveEnter Open