Every CVE Search/ Get API key

CVE-2010-2250

Drupal 6.x before 6.16 uses a user-supplied value in output during site installation which could...

6.1 MediumFix available

CVE-2010-2250 is a medium vulnerability (CVSS 6.1) in Drupal, published March 13, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in drupal6 6.6-3lenny5.

Drupal 5.x and 6.x before 6.16 uses a user-supplied value in output during site installation which could allow an attacker to craft a URL and perform a cross-site scripting attack.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.04%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

Drupal 5.x and 6.x before 6.16 uses a user-supplied value in output during site installation which could allow an attacker to craft a URL and perform a cross-site scripting attack.

Record
CVE-2010-2250
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Drupal 5.x and 6.x before 6.16 uses a user-supplied value in output during site installation which could allow an attacker to craft a URL and perform a cross-site scripting attack.

Record
CVE-2010-2250
Updated
2026-11-02
EUVDEUVD-2010-2262 No score

Drupal 5.x and 6.x before 6.16 uses a user-supplied value in output during site installation which could allow an attacker to craft a URL and perform a cross-site scripting attack.

Record
EUVD-2010-2262
Updated
2026-11-03
GitHub AdvisoriesGHSA-jq73-c7h9-wr72 No score

Drupal 6.x before 6.16 uses a user-supplied value in output during site installation which could...

Drupal 6.x before 6.16 uses a user-supplied value in output during site installation which could allow an attacker to craft a URL and perform a cross-site scripting attack.

Record
GHSA-jq73-c7h9-wr72
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal6
Debian:5.0
before 6.6-3lenny5, plus listed versions
6.6-36.6-3lenny16.6-3lenny26.6-3lenny36.6-3lenny4
6.6-3lenny5

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open