Every CVE Search/ Get API key

CVE-2010-3094

Drupal cross-site scripting vulnerability via actions feature and trigger module

2.1 LowFix available

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.

Exploit likelihood

1.37%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 2.1

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.

Record
CVE-2010-3094
CVSS 2.0
2.1 LowAV:N/AC:H/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.

Record
CVE-2010-3094
Updated
2026-11-02
EUVDEUVD-2022-4784 No score

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.

Record
EUVD-2022-4784
Updated
2026-11-03
GitHub AdvisoriesGHSA-pjmx-4gc6-hwv8 No score

Drupal cross-site scripting vulnerability via actions feature and trigger module

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.

Record
GHSA-pjmx-4gc6-hwv8
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-pjmx-4gc6-hwv8 No score

Drupal cross-site scripting vulnerability via actions feature and trigger module

Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.

Record
GHSA-pjmx-4gc6-hwv8
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/drupal
Packagist
6.0 up to 6.18
6.18
drupal6
Debian:5.0
From an advisory covering 6 CVEs
before 6.6-3lenny6, plus listed versions
6.6-36.6-3lenny16.6-3lenny26.6-3lenny36.6-3lenny46.6-3lenny5
6.6-3lenny6

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-3094 is a low vulnerability (CVSS 2.1) in Drupal, published September 20, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in drupal/drupal 6.18.

References

Show 4 moreShow less
MoveEnter Open