CVE-2010-3276
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to...
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an NSV file.
Exploit likelihood
What each source reports
NVD Score used
9.3
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an NSV file.
- Record
CVE-2010-3276- CVSS 2.0
- 9.3 High
AV:N/AC:M/Au:N/C:C/I:C/A:C - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an NSV file.
- Record
CVE-2010-3276- Updated
- 2026-11-02
EUVDEUVD-2010-3275 No score
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an NSV file.
- Record
EUVD-2010-3275- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7gp9-qpvg-436r No score
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to...
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an NSV file.
- Record
GHSA-7gp9-qpvg-436r- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an NSV file.
- Record
CVE-2010-3276- Updated
- 2026-11-02
OSVDEBIAN-CVE-2010-3276 No score
libdirectx_plugin.dll in VideoLAN VLC Media Player before 1.1.8 allows remote attackers to execute arbitrary code via a crafted width in an NSV file.
- Record
DEBIAN-CVE-2010-3276- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vlcDebian:12 |
before 1.1.8-1 | 1.1.8-1 |
vlcDebian:13 |
before 1.1.8-1 | 1.1.8-1 |
vlcDebian:14 |
before 1.1.8-1 | 1.1.8-1 |
vlcDebian:6.0 From an advisory covering 2 CVEs |
before 1.1.3-1squeeze4, plus listed versions 1.1.3-1squeeze21.1.3-1squeeze3 |
1.1.3-1squeeze4 |
vlcDebian:5.0 From an advisory covering 2 CVEs |
before 0.8.6.h-4+lenny3, plus listed versions 0.8.6.h-4+lenny20.8.6.h-4+lenny2.3 |
0.8.6.h-4+lenny3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2010-3276 is a high vulnerability (CVSS 9.3) in Videolan Vlc Media Player, published March 28, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.46%, the 94th percentile. Fixed in vlc 1.1.8-1.
References
securitytracker.com/id?1025250
oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A14873
vupen.com/english/advisories/2011/0759
videolan.org/vlc/releases/1.1.8.html
secunia.com/advisories/43826
coresecurity.com/content/vlc-vulnerabilities-amv-nsv-files
Show 9 moreShow less
debian.org/security/2011/dsa-2211
securityfocus.com/archive/1/517150/100/0/threaded
exchange.xforce.ibmcloud.com/vulnerabilities/66260
securityreason.com/securityalert/8162
osvdb.org/71278
securityfocus.com/bid/47012
nvd.nist.gov/vuln/detail/CVE-2010-3276
github.com/advisories/GHSA-7gp9-qpvg-436r
security-tracker.debian.org/tracker/CVE-2010-3276