Every CVE Search/ Get API key

CVE-2010-3430

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM ...

4.7 MediumFix available

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Exploit likelihood

0.34%Down 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.7

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Record
CVE-2010-3430
CVSS 2.0
4.7 MediumAV:L/AC:M/Au:N/C:C/I:N/A:N
Updated
2026-11-02
CVE List No score

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Record
CVE-2010-3430
Updated
2026-11-02
EUVDEUVD-2010-3428 No score

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Record
EUVD-2010-3428
Updated
2026-11-03
GitHub AdvisoriesGHSA-fw5v-fh36-5x5q No score

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM ...

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Record
GHSA-fw5v-fh36-5x5q
Updated
2026-11-02
OSVBELL-CVE-2010-3430 4.7

CVE-2010-3430 does not affect BellSoft software

Record
BELL-CVE-2010-3430
CVSS 2.0
4.7 MediumAV:L/AC:M/Au:N/C:C/I:N/A:N
Updated
2026-11-02
OSV No score

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Record
CVE-2010-3430
Updated
2026-11-02
OSVDEBIAN-CVE-2010-3430 No score

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

Record
DEBIAN-CVE-2010-3430
Updated
2026-11-02
OSVopenSUSE-SU-2024:10405-1 No score

pam-1.3.0-3.4 on GA media

These are all security issues fixed in the pam-1.3.0-3.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10405-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pam
Debian:12
before 1.1.3-1
1.1.3-1
pam
Debian:13
before 1.1.3-1
1.1.3-1
pam
Debian:14
before 1.1.3-1
1.1.3-1
pam
openSUSE:Tumbleweed
before 1.3.0-3.4
1.3.0-3.4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-3430 is a medium vulnerability (CVSS 4.7) in Linux-pam, published January 24, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in pam 1.1.3-1.

References

Show 22 moreShow less
MoveEnter Open