CVE-2010-3660
TYPO3 is vulnerable to Cross-Site Scripting (XSS) on the backend
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.
- Record
CVE-2010-3660- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.
- Record
CVE-2010-3660- Updated
- 2026-11-02
EUVDEUVD-2022-1706 No score
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.
- Record
EUVD-2022-1706- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cg45-qgcf-hf9x
5.4
TYPO3 is vulnerable to Cross-Site Scripting (XSS) on the backend
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.
- Record
GHSA-cg45-qgcf-hf9x- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-cg45-qgcf-hf9x
5.4
TYPO3 is vulnerable to Cross-Site Scripting (XSS) on the backend
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.
- Record
GHSA-cg45-qgcf-hf9x- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cms-backendPackagist |
before 4.1.14 | 4.1.14 |
typo3/cms-backendPackagist |
4.2.0 up to 4.2.13 | 4.2.13 |
typo3/cms-backendPackagist |
4.3.0 up to 4.3.4 | 4.3.4 |
typo3/cms-backendPackagist |
4.4.0 up to 4.4.1 | 4.4.1 |
typo3-srcDebian:5.0 From an advisory covering 16 CVEs |
before 4.2.5-1+lenny4, plus listed versions 4.2.5-14.2.5-1+lenny14.2.5-1+lenny24.2.5-1+lenny3 |
4.2.5-1+lenny4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2010-3660 is a medium vulnerability (CVSS 5.4) in Typo3, published August 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 56th percentile. Fixed in typo3/cms-backend 4.1.14.