CVE-2010-3671
TYPO3 is vulnerable to Session Fixation
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
- Record
CVE-2010-3671- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 2.0
- 9.4 High
AV:N/AC:L/Au:N/C:C/I:C/A:N - Weakness
- CWE-384
- Updated
- 2026-11-02
CVE List No score
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
- Record
CVE-2010-3671- Updated
- 2026-11-02
EUVDEUVD-2022-1745 No score
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
- Record
EUVD-2022-1745- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gqmh-5xmq-3fhg
6.5
TYPO3 is vulnerable to Session Fixation
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
- Record
GHSA-gqmh-5xmq-3fhg- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-384
- Updated
- 2026-11-02
OSVGHSA-gqmh-5xmq-3fhg
6.5
TYPO3 is vulnerable to Session Fixation
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
- Record
GHSA-gqmh-5xmq-3fhg- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-384
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cms-installPackagist |
before 4.1.14 | 4.1.14 |
typo3/cms-installPackagist |
4.2.0 up to 4.2.13 | 4.2.13 |
typo3/cms-installPackagist |
4.3.0 up to 4.3.4 | 4.3.4 |
typo3/cms-installPackagist |
4.4.0 up to 4.4.1 | 4.4.1 |
typo3-srcDebian:5.0 From an advisory covering 16 CVEs |
before 4.2.5-1+lenny4, plus listed versions 4.2.5-14.2.5-1+lenny14.2.5-1+lenny24.2.5-1+lenny3 |
4.2.5-1+lenny4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2010-3671 is a medium vulnerability (CVSS 6.5) in Typo3, published August 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.59%, the 75th percentile. Fixed in typo3/cms-install 4.1.14.
References
security-tracker.debian.org/tracker/CVE-2010-3671
bugs.debian.org/cgi-bin/bugreport.cgi?bug=590719
typo3.org/security/advisory/typo3-sa-2010-012
nvd.nist.gov/vuln/detail/CVE-2010-3671
github.com/TYPO3/typo3/commit/199cc2d53747d76657d7aab612c6b3f728d0f15d
github.com/TYPO3/typo3/commit/1d649976e1f1bda684cdc7120e9f74a543059181