CVE-2010-3672
TYPO3 vulnerable to Cross-Site Scripting in the textarea view helper
TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.
- Record
CVE-2010-3672- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.
- Record
CVE-2010-3672- Updated
- 2026-11-02
EUVDEUVD-2022-1794 No score
TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.
- Record
EUVD-2022-1794- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p78x-93mq-qwqh
6.1
TYPO3 vulnerable to Cross-Site Scripting in the textarea view helper
TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.
- Record
GHSA-p78x-93mq-qwqh- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-p78x-93mq-qwqh
6.1
TYPO3 vulnerable to Cross-Site Scripting in the textarea view helper
TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.
- Record
GHSA-p78x-93mq-qwqh- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cms-fluidPackagist |
before 4.3.4 | 4.3.4 |
typo3/cms-fluidPackagist |
4.4.0 up to 4.4.1 | 4.4.1 |
typo3-srcDebian:5.0 From an advisory covering 16 CVEs |
before 4.2.5-1+lenny4, plus listed versions 4.2.5-14.2.5-1+lenny14.2.5-1+lenny24.2.5-1+lenny3 |
4.2.5-1+lenny4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2010-3672 is a medium vulnerability (CVSS 6.1) in Typo3, published August 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.95%, the 61st percentile. Fixed in typo3/cms-fluid 4.3.4.
References
security-tracker.debian.org/tracker/CVE-2010-3672
typo3.org/security/advisory/typo3-sa-2010-012
bugs.debian.org/cgi-bin/bugreport.cgi?bug=590719
nvd.nist.gov/vuln/detail/CVE-2010-3672
github.com/TYPO3/typo3/commit/5f13c2276c8b753ceb76b31d1034a47c781d302a
github.com/TYPO3/typo3/commit/fc2b43503d871b42c0e0094ea55756c089b536ea
github.com/TYPO3-CMS/fluid/blob/cbce111326850c247729f097b2d1fb735e513906/Classes/ViewHelpers/Form/TextareaViewHelper.php
github.com/advisories/GHSA-p78x-93mq-qwqh
github.com/TYPO3-CMS/core