Every CVE Search/ Get API key

CVE-2010-4340

Apache Libcloud does not verify SSL certificates for HTTPS connections

4.3 MediumFix available

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Exploit likelihood

1.38%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Record
CVE-2010-4340
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Record
CVE-2010-4340
Updated
2026-11-02
EUVDEUVD-2011-0001 No score

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Record
EUVD-2011-0001
Updated
2026-11-03
GitHub AdvisoriesGHSA-w3j6-8j34-q43x 8.7

Apache Libcloud does not verify SSL certificates for HTTPS connections

libcloud before 0.4.0 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack. This is due to an upstream issue with python's SSL module rather than directly with libcloud.

Record
GHSA-w3j6-8j34-q43x
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVGHSA-w3j6-8j34-q43x 8.7

Apache Libcloud does not verify SSL certificates for HTTPS connections

libcloud before 0.4.0 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack. This is due to an upstream issue with python's SSL module rather than directly with libcloud.

Record
GHSA-w3j6-8j34-q43x
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-295
Updated
2026-11-02
OSV No score

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Record
CVE-2010-4340
Updated
2026-11-02
OSVDEBIAN-CVE-2010-4340 No score

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Record
DEBIAN-CVE-2010-4340
Updated
2026-11-02
OSVPYSEC-2011-24 No score

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM) attack.

Record
PYSEC-2011-24
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache-libcloud
PyPI
before 0.4.0
0.4.0
libcloud
Debian:12
before 0.5.0-1
0.5.0-1
libcloud
Debian:13
before 0.5.0-1
0.5.0-1
libcloud
Debian:14
before 0.5.0-1
0.5.0-1
apache-libcloud
PyPI
before 0.4.0, plus listed versions
0.3.1
0.4.0
apache-libcloud
PyPI
before 0.4.2, plus listed versions
0.3.10.4.0
0.4.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-4340 is a medium vulnerability (CVSS 4.3) in Apache Libcloud, published September 11, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.38%, the 72nd percentile. Fixed in apache-libcloud 0.4.0.

References

Show 7 moreShow less
MoveEnter Open