CVE-2010-4616
ImpressCMS Cross-site Scripting vulnerability via quicksearch_ContentContent parameter
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.
- Record
CVE-2010-4616- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.
- Record
CVE-2010-4616- Updated
- 2026-11-02
EUVDEUVD-2022-2154 No score
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.
- Record
EUVD-2022-2154- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-39vm-rvwh-q86j No score
ImpressCMS Cross-site Scripting vulnerability via quicksearch_ContentContent parameter
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.
- Record
GHSA-39vm-rvwh-q86j- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-39vm-rvwh-q86j No score
ImpressCMS Cross-site Scripting vulnerability via quicksearch_ContentContent parameter
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearch_ContentContent parameter.
- Record
GHSA-39vm-rvwh-q86j- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
impresscms/impresscmsPackagist |
before 1.2.4 | 1.2.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2010-4616 is a medium vulnerability (CVSS 4.3) in Impresscms, published December 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in impresscms/impresscms 1.2.4.
References
htbridge.ch/advisory/xss_vulnerability_in_impresscms.html
community.impresscms.org/modules/smartsection/item.php?itemid=525
secunia.com/advisories/42695
securityfocus.com/archive/1/515397/100/0/threaded
nvd.nist.gov/vuln/detail/CVE-2010-4616
web.archive.org/web/20101223135531/http://secunia.com/advisories/42695
web.archive.org/web/20201209001614/http://www.securityfocus.com/archive/1/515397/100/0/threaded
github.com/advisories/GHSA-39vm-rvwh-q86j
github.com/ImpressCMS/impresscms