Every CVE Search/ Get API key

CVE-2010-5106

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly...

6.5 MediumFix available

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly check capabilities, which allows remote authenticated users to bypass intended access restrictions, and publish, edit, or delete posts, by leveraging the Author or Contributor role.

Exploit likelihood

2.18%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly check capabilities, which allows remote authenticated users to bypass intended access restrictions, and publish, edit, or delete posts, by leveraging the Author or Contributor role.

Record
CVE-2010-5106
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly check capabilities, which allows remote authenticated users to bypass intended access restrictions, and publish, edit, or delete posts, by leveraging the Author or Contributor role.

Record
CVE-2010-5106
Updated
2026-11-02
EUVDEUVD-2010-5066 No score

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly check capabilities, which allows remote authenticated users to bypass intended access restrictions, and publish, edit, or delete posts, by leveraging the Author or Contributor role.

Record
EUVD-2010-5066
Updated
2026-11-03
GitHub AdvisoriesGHSA-2w3h-g44g-mrhv No score

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly...

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly check capabilities, which allows remote authenticated users to bypass intended access restrictions, and publish, edit, or delete posts, by leveraging the Author or Contributor role.

Record
GHSA-2w3h-g44g-mrhv
Updated
2026-11-02
OSV No score

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly check capabilities, which allows remote authenticated users to bypass intended access restrictions, and publish, edit, or delete posts, by leveraging the Author or Contributor role.

Record
CVE-2010-5106
Updated
2026-11-02
OSVDEBIAN-CVE-2010-5106 No score

The XML-RPC remote publishing interface in xmlrpc.php in WordPress before 3.0.3 does not properly check capabilities, which allows remote authenticated users to bypass intended access restrictions, and publish, edit, or delete posts, by leveraging the Author or Contributor role.

Record
DEBIAN-CVE-2010-5106
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Debian:12
before 3.0.3-1
3.0.3-1
wordpress
Debian:13
before 3.0.3-1
3.0.3-1
wordpress
Debian:14
before 3.0.3-1
3.0.3-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-5106 is a medium vulnerability (CVSS 6.5) in Wordpress, published September 14, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.18%, the 82nd percentile. Fixed in wordpress 3.0.3-1.

References

MoveEnter Open