Every CVE Search/ Get API key

CVE-2011-0528

Puppet does not properly restrict access to node resources

5.5 MediumFix available

CVE-2011-0528 is a medium vulnerability (CVSS 5.5) in Puppet, published February 17, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.65%, the 76th percentile. Fixed in puppet 2.6.4.

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Exploit likelihood

1.65%Up 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Record
CVE-2011-0528
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:N
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Record
CVE-2011-0528
Updated
2026-11-02
EUVDEUVD-2022-3428 No score

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Record
EUVD-2022-3428
Updated
2026-11-03
GitHub AdvisoriesGHSA-9pvx-fwwh-w289 No score

Puppet does not properly restrict access to node resources

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Record
GHSA-9pvx-fwwh-w289
Weakness
CWE-284
Updated
2026-11-02
OSV No score

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Record
CVE-2011-0528
Updated
2026-11-02
OSVDEBIAN-CVE-2011-0528 No score

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Record
DEBIAN-CVE-2011-0528
Updated
2026-11-02
OSVGHSA-9pvx-fwwh-w289 No score

Puppet does not properly restrict access to node resources

Puppet 2.6.0 through 2.6.3 does not properly restrict access to node resources, which allows remote authenticated Puppet nodes to read or modify the resources of other nodes via unspecified vectors.

Record
GHSA-9pvx-fwwh-w289
Weakness
CWE-284
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet
RubyGems
2.6.0 to 2.6.3
2.6.4
puppet
Debian:11
before 2.6.2-3
2.6.2-3
puppet
RubyGems
2.6.0 up to 2.6.4, plus listed versions
2.6.12.6.22.6.3
2.6.4

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 5 moreShow less
MoveEnter Open