Every CVE Search/ Get API key

CVE-2011-0628

Integer overflow in Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and...

9.3 HighFix available

CVE-2011-0628 is a high vulnerability (CVSS 9.3) in Adobe Flash Player, published May 31, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.27%, the 93rd percentile. Fixed in flash-plugin 0:10.3.181.14-1.el5.

Integer overflow in Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solaris and before 10.3.185.21 on Android allows remote attackers to execute arbitrary code via ActionScript that improperly handles a long array object.

Exploit likelihood

6.27%Down 1.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Integer overflow in Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solaris and before 10.3.185.21 on Android allows remote attackers to execute arbitrary code via ActionScript that improperly handles a long array object.

Record
CVE-2011-0628
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solaris and before 10.3.185.21 on Android allows remote attackers to execute arbitrary code via ActionScript that improperly handles a long array object.

Record
CVE-2011-0628
Updated
2026-11-02
EUVDEUVD-2011-0646 No score

Integer overflow in Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solaris and before 10.3.185.21 on Android allows remote attackers to execute arbitrary code via ActionScript that improperly handles a long array object.

Record
EUVD-2011-0646
Updated
2026-11-03
GitHub AdvisoriesGHSA-9wgf-m28w-v7xf No score

Integer overflow in Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and...

Integer overflow in Adobe Flash Player before 10.3.181.14 on Windows, Mac OS X, Linux, and Solaris and before 10.3.185.21 on Android allows remote attackers to execute arbitrary code via ActionScript that improperly handles a long array object.

Record
GHSA-9wgf-m28w-v7xf
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-plugin
Red Hat:rhel_extras:5::client
before 0:10.3.181.14-1.el5
0:10.3.181.14-1.el5
flash-plugin
Red Hat:rhel_extras:5::server
before 0:10.3.181.14-1.el5
0:10.3.181.14-1.el5
flash-plugin
Red Hat:rhel_extras:6
before 0:10.3.181.14-1.el6
0:10.3.181.14-1.el6

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 41 moreShow less
MoveEnter Open