Every CVE Search/ Get API key

CVE-2011-0707

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and...

4.3 MediumFix available

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) full name or (2) username field in a confirmation message.

Exploit likelihood

4.25%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) full name or (2) username field in a confirmation message.

Record
CVE-2011-0707
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) full name or (2) username field in a confirmation message.

Record
CVE-2011-0707
Updated
2026-11-02
EUVDEUVD-2011-0722 No score

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) full name or (2) username field in a confirmation message.

Record
EUVD-2011-0722
Updated
2026-11-03
GitHub AdvisoriesGHSA-24m7-q6q4-w3hx No score

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and...

Multiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) full name or (2) username field in a confirmation message.

Record
GHSA-24m7-q6q4-w3hx
Weakness
CWE-79
Updated
2026-11-02
OSVopenSUSE-SU-2024:10215-1 No score

mailman-2.1.23-1.2 on GA media

These are all security issues fixed in the mailman-2.1.23-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10215-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mailman
Debian:5.0
before 1:2.1.11-11+lenny2, plus listed versions
1:2.1.11-111:2.1.11-11+lenny1
1:2.1.11-11+lenny2
mailman
Debian:6.0
before 1:2.1.13-5, plus listed versions
1:2.1.13-4.1
1:2.1.13-5
mailman
Red Hat:enterprise_linux:4::as
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
mailman-debuginfo
Red Hat:enterprise_linux:4::as
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
mailman
Red Hat:enterprise_linux:4::desktop
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
mailman-debuginfo
Red Hat:enterprise_linux:4::desktop
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
mailman
Red Hat:enterprise_linux:4::es
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
mailman-debuginfo
Red Hat:enterprise_linux:4::es
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
mailman
Red Hat:enterprise_linux:4::ws
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
mailman-debuginfo
Red Hat:enterprise_linux:4::ws
before 3:2.1.5.1-34.rhel4.7
3:2.1.5.1-34.rhel4.7
Show 7 moreShow less
Affected packages
PackageAffectedFixed
mailman
Red Hat:enterprise_linux:5::server
before 3:2.1.9-6.el5_6.1
3:2.1.9-6.el5_6.1
mailman-debuginfo
Red Hat:enterprise_linux:5::server
before 3:2.1.9-6.el5_6.1
3:2.1.9-6.el5_6.1
mailman
Red Hat:enterprise_linux:6::server
before 3:2.1.12-14.el6_0.2
3:2.1.12-14.el6_0.2
mailman-debuginfo
Red Hat:enterprise_linux:6::server
before 3:2.1.12-14.el6_0.2
3:2.1.12-14.el6_0.2
mailman
Red Hat:enterprise_linux:6::workstation
before 3:2.1.12-14.el6_0.2
3:2.1.12-14.el6_0.2
mailman-debuginfo
Red Hat:enterprise_linux:6::workstation
before 3:2.1.12-14.el6_0.2
3:2.1.12-14.el6_0.2
mailman
openSUSE:Tumbleweed
before 2.1.23-1.2
2.1.23-1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-0707 is a medium vulnerability (CVSS 4.3) in Gnu Mailman, published February 18, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.25%, the 91st percentile. Fixed in mailman 1:2.1.11-11+lenny2.

References

Show 45 moreShow less
MoveEnter Open