Every CVE Search/ Get API key

CVE-2011-1088

Apache Tomcat allows remote attackers to bypass intended access restrictions

5.8 MediumFix available

Apache Tomcat 7.x before 7.0.10 does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application.

Exploit likelihood

6.45%Up 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.8

Apache Tomcat 7.x before 7.0.10 does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application.

Record
CVE-2011-1088
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Updated
2026-11-02
CVE List No score

Apache Tomcat 7.x before 7.0.10 does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application.

Record
CVE-2011-1088
Updated
2026-11-02
EUVDEUVD-2022-4557 No score

Apache Tomcat 7.x before 7.0.10 does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application.

Record
EUVD-2022-4557
Updated
2026-11-03
GitHub AdvisoriesGHSA-mg4v-rf8p-ghqq No score

Apache Tomcat allows remote attackers to bypass intended access restrictions

Apache Tomcat 7.x before 7.0.10 does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application.

Record
GHSA-mg4v-rf8p-ghqq
Updated
2026-11-02
OSVGHSA-mg4v-rf8p-ghqq No score

Apache Tomcat allows remote attackers to bypass intended access restrictions

Apache Tomcat 7.x before 7.0.10 does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application.

Record
GHSA-mg4v-rf8p-ghqq
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.tomcat:tomcat
Maven
7.0.0 up to 7.0.10
7.0.10

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1088 is a medium vulnerability (CVSS 5.8) in Apache Tomcat, published March 14, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.45%, the 93rd percentile. Fixed in org.apache.tomcat:tomcat 7.0.10.

References

Show 32 moreShow less
MoveEnter Open